Articles of android gradle

Я получаю только app-release-unaligned.apk, когда я нажимаю сгенерировать подписанный apk

Я всегда получаю «app-release-unaligned.apk». Я не могу получить «app-release.apk». Но прежде чем я обновил Android SDK, я могу получить как «app-release.apk», так и «app-release-unaligned.apk» после нажатия «Build-> Generate Signed Apk …» Система Mac OS. Android Studio 1.5.1. Android SDK Tools 25.1.1. Платформа для Android SDK 23.1. Android SDK Build-tools 23.0.3. Я нашел подобную проблему в […]

Можно ли использовать несколько файлов манифеста для разных градиентных сборок / ароматов?

Допустим, у меня есть приложение с белой меткой, которое Im конвертирует, чтобы быть встроенным в студию Android из eclipse. Это приложение имеет около 10 итераций, которые используют в основном одну и ту же базу кода с разными ресурсами, которые используют одно и то же название, поскольку некоторые из итераций имеют дополнительные действия или службы, которые […]

Jacoco конвертирует coverage.ec в отчеты без покрытия.

Мне удалось получить отчет о покрытии кода, выполнив следующие шаги: Включить покрытие по типу сборки, который вы хотите (например, отладить) buildTypes { debug { testCoverageEnabled true } } Применить плагин Jacoco и установить версию apply plugin: 'jacoco' jacoco { version "0.7.1.201405082137" } Бег ./gradlew createDebugCoverageReport Все тесты в connectedAndroidTest запускаются, и отчет о покрытии создается […]

Зависимость HTTP-клиента apache в андроиде с API Google

Я использую библиотеки игровых сервисов google только с регистрацией в Google+, и она отлично работает, но теперь я хочу включить в приложение приложение «Календарь». Я следую этому руководству Проблема заключается в том, что зависимости от новых инструкций учебника вызывают предупреждение в Gradle Build. Information:Gradle tasks [:app:generateDebugSources, :app:generateDebugAndroidTestSources] Warning:Dependency org.apache.httpcomponents:httpclient:4.0.1 is ignored for debug as it […]

Как игнорировать minSdkVersion библиотеки в Android Studio?

В моем проекте minSdkVersion = 10, в библиотеке – 11. Я получил: BUILD_FAILED – Manifest merger failed : uses-sdk:minSdkVersion 10 cannot be smaller than version 11 declared in library. Как игнорировать minSdkVersion библиотеки?

Android: Выполнение не выполнено для задачи ': app: packageDebug'. > Данные

Я только что создал образец проекта и столкнулся с этой проблемой. Может ли кто-нибудь помочь в решении этого? * What went wrong: Execution failed for task ':app:packageDebug'. > data * Try: Run with –info or –debug option to get more log output. * Exception is: org.gradle.api.tasks.TaskExecutionException: Execution failed for task ':app:packageDebug'. at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.executeActions(ExecuteActionsTaskExecuter.java:69) at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.execute(ExecuteActionsTaskExecuter.java:46) […]

Android Studio 1.1 Gradle 2.2.1 Gradle версии 2.1 требуется текущая версия 2.2.1

Я просто пытаюсь скомпилировать последнюю версию u2020-daggr2 в Android stu! [E Я импортировал ее как проект градиента. Но я получаю ошибку, жалуясь на град! Я редактировал gradle-wrapper.properties. Однако перестройка не сработала. Я видел: требуется Gradle 2.1. Миграция в Gradle wrapper и проект синхронизации, который кажется такой же проблемой, но на Studio I не нашел: Настройки […]

Дженкинс не может решить com.android.tools.build:gradle:3.0.0-alpha8

Я обновился до версии 3.0 для Android Studio Canary 8 и последовал за автоматическим запросом на студию Android, чтобы обновить версию плагина android gradle до «3.0.0-alpha8». Моя сборка Jenkins теперь не позволяет решить «com.android.tools.build:gradle:3.0.0-alpha8.». Ниже приведены журналы ошибок построения Could not resolve all files for configuration ':classpath'. Could not find com.android.tools.build:gradle:3.0.0-alpha8. Searched in the following […]

Неподдерживаемый тип 'свойство' в файле logback.xml

Я хочу использовать logback-android в проекте Android. Вот что я сделал Я скопировал файлы jar в папку libs Logback-андроид-1.1.1-2.jar SLF4J-апи-1.7.6.jar И имеет logback.xml в папке с ресурсами <configuration debug="true"> <property name="LOG_DIR" value="/mnt/sdcard/com.sf.quid/logs" /> <!– Create a logcat appender –> <appender name="LOG_CAT" class="ch.qos.logback.classic.android.LogcatAppender"> <encoder> <pattern>%msg</pattern> </encoder> </appender> <!– Rolling Appender –> <appender name="FILE" class="ch.qos.logback.core.rolling.RollingFileAppender"> <!– File […]

Android-студия Gradle :: dependencies {compile 'com.android.support:appcompat-v7:18.0.0'} завершает компиляцию

Недавно я перешел на андроид-студию для разработки. Я создал проект с minsdk, targetdk и скомпилировал с помощью sdk как Google Api Level 8. Компиляция проекта не выполняется из-за следующего кода в файле build.gradle. dependencies { compile 'com.android.support:appcompat-v7:18.0.0' } Может ли кто-нибудь сказать, почему это происходит? Все мое build.gradle опубликовано ниже. buildscript { repositories { mavenCentral() […]