Articles of android 4.0

Android «Отсутствует контент-провайдер или разрешение на отмену» с помощью андроида 4

У меня есть приложение для Android, которое отлично работает на Android 2-2 и 2-3. Но когда я пытаюсь установить приложение на Android 4-0 или 4-2-2, я дважды получаю следующую ошибку: Контент-провайдер не найден для отзыва разрешения: файл: ///data/local/tmp/myapp.apk Я узнал, что у других была аналогичная проблема, и я попробовал решения, указанные в следующих ссылках: Невозможно […]

Виджет приложения не отображается в ящике приложений ICS

Кто-нибудь видел, как виджет приложений не отображается в ящике приложений ICS? Первоначально я запустил это приложение для FroYo и ниже, которое прекрасно поддерживает виджет приложения. Вдобавок появились пряники и соты, они тоже работают. Виджет появляется в списке в эмуляторе, если я открою приложение «Просмотр виджета», однако, когда вы просто открываете ящик, он не отображается вместе […]

Широковещательная передача, когда снимок сделан в Android 4.0?

Есть ли способ, которым я могу слушать трансляцию при съемке снимка экрана, или изображение вставлено в MediaStore? Цель: обратная связь.

Создание календаря с провайдером контента Android 4.0 (ICS)

Я пытаюсь создать календарь, используя новый Content Provider для календарей ICS. Поскольку создание календаря возможно только в SyncAdapter, я создал один: public class CalendarSyncAdapter extends AbstractThreadedSyncAdapter { public CalendarSyncAdapter(Context context, boolean autoInitialize) { super(context, autoInitialize); } @Override public void onPerformSync(Account account, Bundle extras, String authority, ContentProviderClient provider, SyncResult syncResult) { Log.i( Debug.TAG, "onPerformSync()" ); } […]

Разделители вкладок не отображаются в ICS

У меня проблема с .setDividerDrawable (), работающая только в версиях ниже Ice Cream Sandwich. Когда я запускаю эмулятор, вкладки показывают отлично, но нет разделителя. При эмуляции более низких версий Android нет проблем, показывают разделители. Я использую этот код для создания TabHost. Я не знаю, что это значит, что ICS вздрогнет. manifest.xml <?xml version="1.0" encoding="utf-8"?> <manifest […]

Проблемы с использованием расширений в tel: гиперссылки на Android 4

У нас есть мобильный веб-сайт с некоторыми номерами телефонов, например: HREF = "тел: 12345678.123" Это отлично работает на большинстве устройств, но похоже, что он не работает на многих / всех устройствах Android 4. Расширение просто не появляется в диалоговом окне при нажатии ссылки. Кто-нибудь нашел решение?

Использование Android WebView для подключения к защищенному серверу с сертификатом клиента

Может ли WebView или, более конкретно, PhoneGaps CordovaWebView, использовать сертификаты клиентов для аутентификации на сервере? Я понимаю, что собственный браузер может использовать клиентские сертификаты, но я пытаюсь заставить Android-приложение PhoneGap разговаривать с сервером, который требует, чтобы клиентский сертификат работал и не мог видеть, как это сделать. Я пробовал различные методы, которые я видел в Google, […]

Эллипс сэндвич мороженого добавляет [

В настоящее время я разрабатываю приложение и просто провел некоторое тестирование на сэндвич с мороженым и заметил некоторое нечетное поведение при использовании свойства android: ellipsize = "end" в текстовом виде. Он добавляет символ после точек. Эта ошибка сводит меня с ума и появляется только в сэндвиче с мороженым. Я видел предыдущий рассказ об этом , […]

Android с поддержкой websocket (Node Websocket server и Android Java Client). Dosen't работает на Android 4

Я пытался использовать в качестве клиента Android Websocket – weberknecht с потоком для отправки каждой секунды сообщения в Nodejs Websocket (js): Node WebSocket Server Он отлично работает на Android 2 или 2.3.3, но когда я нахожусь на android 4, я получаю сообщение об ошибке на websocket.connect (); Вы знаете, почему или что я делаю неправильно? […]

Aapt.exe бросает необработанное исключение, создавая * .apk-файл для Android-проекта в Eclipse

Я просто обновил свою систему до Ice Cream Sandwich (Android 4.0), и теперь каждый раз, когда я пытаюсь запустить приложение в отладчике, я получаю сбой в aapt.exe . Если я только строю, он строит отлично, но когда я иду запускать его в отладчик, aapt.exe сбой aapt.exe (который aapt.exe диалог и спрашивает меня, хочу ли я […]