Articles of Плагины для

Создание плагина helloWorld для Android с использованием Cordova и Eclipse

Я провел немало исследований и не могу найти, почему это не работает. У меня есть приложение для Android на Кордове в Eclipse, работающем на Cordova 2.7.0. Я хочу создать простой плагин, который просто предупреждает пользователя о его завершении. Мой index.html <head> <script type="text/javascript" src="cordova-2.7.0.js"></script> <script> window.func = function(str,callback){ alert("Outside Call Working"); cordova.exec(callback, function(err){alert(err)},"HelloPlugin","echo", [str]); } […]

Невозможно установить Android для Maven Eclipse Plug-in

Возможно, вы подумаете, что это глупый вопрос только для установки плагина. Но, честно говоря, я попробовал 3 раза установить этот плагин. Я следил за этим руководством по сайту: http://rgladwell.github.io/m2e-android/, а также ссылаюсь на часто задаваемый вопрос, который является руководством по добавлению плагина в stackoverflow. (Но я сожалею о том, что не способен Для размещения более […]

Управление плагинами для приложения для Android

Мы хотим разработать и расширять приложение для Android и искать способ обработки плагинов. Как вы думаете, какой лучший подход: Использование пакета PackageManager для Android. Проблема здесь в том, что PM не разработан с учетом плагинов, поэтому нам придется реализовать такие функции, как проверка зависимостей. Использование существующей инфраструктуры Java, такой как JPF (Java Plugin Framework) или […]

Ошибка при использовании примера камеры

Привет, я попытался запустить образец камеры для камеры на моем устройстве Sony Xperia E. Приложение запускается на устройстве правильно, однако, когда я нажимаю кнопку «Захват фотографии», я получил и окно с предупреждением «Не удалось, потому что: класс не найден». В представлении LogCat в eclipse я нашел эти журналы ошибок: W/System.err: java.lang.ClassNotFoundException: org.apache.cordova.CameraLauncher W/System.err: at java.lang.Class.classForName(Native […]

Как я могу определить версию плагина Android Gradle, используемую внутри моего собственного плагина Gradle?

контекст Я пишу плагин Gradle для проектов Android. Мой плагин полагается на некоторые методы из плагина Android Gradle, но точные вызовы, которые мне нужно использовать, изменились по мере развития плагина Android Gradle (например, методы, которые мне нужны, отличаются в v2.1.2 и v2.2.2 плагина Android Gradle ). Я хочу получить версию плагина Android Gradle программно из […]

Кордова 3.5, как обновить локальный плагин?

Я только что создал свой первый плагин Cordova, и я хотел бы спросить, как я могу отразить изменения в файлах, расположенных в: /app/plugins/org.cool.plugin Я изменил содержимое файла plugin.xml и добавил код в класс Java. После этого я запустил команду corova build android, но изменения не доступны на платформах / android / src / … Я […]

Использовать настраиваемый плагин GStreamer на Android

Я разработал плагин GStreamer 1.0, который отлично работает в Windows / Linux и некоторых других системах. Теперь я хочу охватить Android. В настоящее время плагин не интегрирован в GStreamer в том смысле, что он не построен с помощью GStreamer / Cerbero, но он создается отдельно, используя официальные двоичные файлы GStreamer (devel), полученные * .so или […]

Android DDMS уже установлена, поэтому будет выполнено обновление

У меня была та же проблема, что и многие люди при обновлении плагина ADT. Поэтому я использовал описанную здесь процедуру: Сообщение об ошибке: для Android SDK требуется Android Developer Toolkit версии 22.6.1 или выше Итак, я проверил инструменты для разработчиков и нажал следующую кнопку. И это говорит 'Ваш первоначальный запрос был изменен. «Android DDMS», поэтому […]

Android-maven-plugin вызывает java.lang.OutOfMemoryError при попытке создать dex

Мне нужна рука. Я использую android-maven-plugin 3.0.0 и maven-external-dependency-plugin 0.4 в проекте android. Я использую эти библиотеки из разных репозиториев в качестве зависимостей: <dependencies> <dependency> <groupId>junit</groupId> <artifactId>junit</artifactId> <scope>test</scope> </dependency> <dependency> <groupId>com.google.android</groupId> <artifactId>android</artifactId> <scope>provided</scope> </dependency> <dependency> <groupId>com.google.android</groupId> <artifactId>android-test</artifactId> <scope>provided</scope> </dependency> <dependency> <groupId>com.admob.android.ads</groupId> <artifactId>admob-android</artifactId> <version>4.0.4</version> </dependency> <dependency> <groupId>com.google.code</groupId> <artifactId>google-api-translate-java</artifactId> <version>0.97</version> </dependency> <dependency> <groupId>com.db4o</groupId> <artifactId>db4o-core-java5</artifactId> <version>${com.db4o.version}</version> </dependency> <dependency> […]

Window.plugins undefined при попытке использовать плагины phonegap на android

Я не могу загрузить плагины в android. Я добавил плагин в список plugins.xml, добавил Java-код в свой проект. Но все же, когда я вызываю window.plugins я получаю undefined объект. Почему это происходит? BTW Я пытаюсь использовать плагин share – https://github.com/phonegap/phonegap-plugins/tree/master/Android/Share Чтобы быть ясным, я добавил файл phonegap.js и файл share.js, содержащий код плагина JS. Также […]