Articles of Градиент

Добавление внешнего проекта .jar в androidstudio

Я добавил внешнюю библиотеку bsh-2.0b4.jar к проекту android в android-studio, перейдя в Project structure -> Modules -> myProject -> Tab-Dependencies -> + Sign а затем добавьте файл .jar. Я также попытался скопировать файл в каталог / libs, а затем щелкнуть правой кнопкой мыши в студии и add as library… (оба метода независимо !!). Я вставил […]

«Уже добавлено» исключение с ormlite и gradle

Я использую android studio 0.2.3 с градиентом 0.5 и добавил зависимость build.gradle файлу build.gradle следующим образом: compile 'com.j256.ormlite:ormlite-android:4.9' Gradle загрузил два файла jar: ormlite-android.jar и ormlite-core.jar . Проблема состоит в том, что файлы jar содержат одинаково названные классы. Поэтому я получаю следующее известное исключение: UNEXPECTED TOP-LEVEL EXCEPTION: java.lang.IllegalArgumentException: already added: Lcom/j256/ormlite/dao/BaseDaoImpl$1; Некоторое другое решение для […]

Источники и исходные структуры проекта Gradle productflavors

Сегодня я начал конвертировать наш проект, чтобы использовать систему построения градиентов. Я не могу изменить структуру проекта, и у меня разные вкусы, поэтому мне было интересно, как я могу переопределить набор «dev» и «prod», потому что это, по-видимому, не работает: buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.4.2' } } apply plugin: 'android' […]

Проект Android компилируется, но зависимости maven не распознаются в Android Studio

Я добавил Google Play Services в свой Android-проект в зависимости от Gradle. dependencies { compile 'com.google.android.gms:play-services:4.1.32' } Проблема в том, что Android Studio не распознает эту зависимость. Я пробовал синхронизировать проект с файлами gradle, но классы все еще не найдены. Я могу вручную импортировать некоторые классы из Служб Google Play и использовать их в своем […]

Gradle 3.0.0-alpha1 не совместим с плагином kotlin-android 1.1.2-3?

Я устанавливаю Android Studio 3.0 Canary 1 и создаю новый проект с kotlin. И получите эту ошибку: Ошибка: Не удалось найти метод «com.android.build.gradle.internal.variant.BaseVariantData.getOutputs () Ljava / util / List;». Возможные причины этой непредвиденной ошибки: Кэш зависимостей Gradle может быть поврежден (это иногда происходит после таймаута сетевого соединения.) Заново загружать зависимости и проект синхронизации (требуется сеть) […]

Как добавить ActiveAndroid ORM в Gradle?

Я создаю приложение для Android, в котором я хочу использовать ORM ActiveAndroid . В readme я прочитал инструкции о том, как включить его в Maven или ADT, но я использую / пытаюсь изучить Android Studio с Gradle. Поэтому, я думаю, мне нужно вставить ActiveAndroid в качестве зависимости. В файле build.gradle в этих строках: dependencies { […]

Как правильно настроить Android Studio (minSdkVersion из) AndroidManifest.xml?

У меня есть проект Android, который был создан в Eclipse, экспортирован как файл сборки Gradle , а затем открыт в Android Studio. (Да, было бы намного проще создать чистый проект в AS, но мне нужно поддержать текущую структуру проекта.) В противном случае вещи теперь в основном работают, но все еще есть кое-что, что нужно сгладить. […]

Проблема с Android Studio – преждевременный конец файла

Я использую Android Studio 0.2.6 в Mac Mountain Lion. Когда я запускаю проект в первый раз, он работает нормально. Но в следующий раз, у меня есть следующая ошибка: Internal error: (org.jdom.input.JDOMParseException) Error on line 1: Premature end of file. org.jdom.input.JDOMParseException: Error on line 1: Premature end of file. at org.jdom.input.SAXBuilder.build(SAXBuilder.java:533) at org.jdom.input.SAXBuilder.build(SAXBuilder.java:946) at com.intellij.openapi.util.JDOMUtil.loadDocument(JDOMUtil.java:377) at […]

Ошибка: java.util.concurrent.ExecutionException: com.android.ide.common.process.ProcessException:

Это результат моей консоли gradle, пожалуйста, помогите мне решить эту ошибку, я не могу построить свой проект Information:Gradle tasks [:facebook:generateDebugSources, :facebook:mockableAndroidJar, :facebook:prepareDebugUnitTestDependencies, :facebook:generateDebugAndroidTestSources, :lagaiKhai:generateDebugSources, :lagaiKhai:mockableAndroidJar, :lagaiKhai:prepareDebugUnitTestDependencies, :lagaiKhai:generateDebugAndroidTestSources] Error:java.util.concurrent.ExecutionException: com.android.ide.common.process.ProcessException: Error:Execution failed for task ':lagaiKhai:mergeDebugResources'. > Error: java.util.concurrent.ExecutionException: com.android.ide.common.process.ProcessException: Information:BUILD FAILED Information:Total time: 23.24 secs Information:2 errors Information:0 warnings Information:See complete output in console

Службы Google Play GCM 10.0.1 требуют «обновить» до 9.0.0

Я пытаюсь построить свой новый проект, но я получаю эту ошибку: Ошибка: выполнение выполнено для задачи ': mobile: processDebugGoogleServices'. Исправьте конфликт версии либо путем обновления версии плагина google-services (информация о последней версии доступна на странице https://bintray.com/android/android-tools/com.google.gms.google-services/ ) Или обновить версию com.google.android.gms до 9.0.0. apply plugin: 'com.android.application' apply plugin: 'com.google.gms.google-services' android { compileSdkVersion 25 buildToolsVersion "25.0.1" […]