Articles of Градиент

JniLibs не расширены в градусах

Приложение Android имеет два модуля и один зависит от другого, а общие используемые банки и собственные библиотеки определяются в parent-project , тогда как child-project добавляет его как зависимость в build.gradle: Однако после того, как я создаю child-project я обнаружил, что баны помещают iniede, parent-project копируется в apk, а родные библиотеки – нет. В apk упаковываются […]

Ошибка: обновлено обновление проекта «Приветствие» в Gradle: Ошибка сборки скрипта, неподдерживаемый метод DSL-меток Gradle: «setRoot ()»!

Привет, я делаю тестирование своего приложения для Android, используя gradle в AndroidStudio . Я использую эту инфраструктуру RoboLectric для выполнения всего этого. Это дает мне ошибку, когда я синхронизую его с файлами gradle . Ребята, поделитесь своими взглядами на эту проблему. Gradle settings 3:35:14 PM Gradle 'HelloWorld' project refresh failed: Build script error, unsupported Gradle […]

В магазине Play отображается 0 поддерживаемых устройств с одинаковым кодом

Я попытался загрузить новую версию своего приложения (например: v1.0.4), чтобы играть в хранилище, и он показывает 0 поддерживаемых устройств. Для тестирования я откинул свою старую версию (например: v1.0.2), изменил только код версии / имя в файле gradle и попытался снова загрузить apk. Он также показывает 0 поддерживаемых устройств. Несколько дней назад эта версия (v1.0.2) поддерживала […]

Службы Google Play в проекте Android Studio 0.1.1?

Последнее обновление для Android-студии не позволяет получить доступ к графическому интерфейсу структуры проекта из проекта, который использует gradle. Хотя я настроил сценарий gradle для использования сервисов Google Play, по какой-то причине я все еще не могу использовать библиотеку. Вот что я сделал: Создал новый Android-проект Создал папку с именем «libraries» в корневом каталоге проекта Скопировала […]

Правильный способ добавления глобальной библиотеки в android-studio / gradle

Прежде всего, я знаю, как добавить локальную библиотеку в файл build.gradle , здесь уже обсуждались несколько вопросов (которые в основном одинаковы), см. Здесь , здесь и здесь . Но вы должны жестко кодировать пути в compile files('/path/to/lib.jar') в файле build.gradle , что не является хорошим, а не распространяемым и т. Д., Если вы используете библиотеку, […]

Не удалось найти свойство VERSION_CODE

Я хочу использовать эту библиотеку для своего проекта, и у меня возникла ошибка при попытке открыть этот источник (FloatingActionButton) из Github. Я загружаю как zip этот проект, когда я пытался открыть исходный код, чтобы понять его, я получил эту ошибку: Error:(10, 0) Could not find property 'VERSION_CODE' on project ':library'. Добавить build.gradle apply plugin: 'com.android.library' […]

Привязка данных Android: невозможно разрешить символ

Я попытался использовать бета-функции (привязка данных) в студии Android. После того, как после руководства от android studio, я могу найти связанный класс DataBindingInfo в студии android. Но класс создания данных не генерируется после создания проекта. Может кто-нибудь помочь? Build.gradle для модуля приложения apply plugin: 'com.android.application' apply plugin: 'com.android.databinding' android { compileSdkVersion 23 buildToolsVersion "23.0.1" defaultConfig […]

Можно ли использовать несколько файлов манифеста для разных градиентных сборок / ароматов?

Допустим, у меня есть приложение с белой меткой, которое Im конвертирует, чтобы быть встроенным в студию Android из eclipse. Это приложение имеет около 10 итераций, которые используют в основном одну и ту же базу кода с разными ресурсами, которые используют одно и то же название, поскольку некоторые из итераций имеют дополнительные действия или службы, которые […]

Ошибка настройки библиотеки поддержки Android

Я выполнил команду http://developer.android.com/tools/support-library/setup.html, чтобы добавить библиотеку поддержки в мой проект Android, но получил ошибку сборки, подобную этой Gradle: возникла проблема с оценкой проекта ': projectname'. Нет подписи метода: org.gradle.api.internal.artifacts.dsl.dependencies.DefaultDependencyHandler.compile () применим для типов аргументов: (java.lang.String) значения: [com.android.support:appcompat-v7: 18.0. +] Возможные решения: module (java.lang.Object) Кто-нибудь знает причину этого? Это синтаксическая ошибка в градиенте? Ниже приведен […]

Commons-Io Duplicate Entry Error с использованием Robospice и Android Studio

Я работаю над следующей проблемой в течение нескольких часов, но не придумал способ решить мою проблему. Я попробовал следующие исправления от Stack Overflow ( обновление Android Studio до 1.0 развращает MultiDex и Duplicate Zip Entry после Gradle Plugin v0.13.1 ), но ни один из них не работал. При попытке создать мою программу возникает следующая ошибка: […]