Articles of Версия для

Могу ли я установить только новейший Android API для более низкой версии API?

Скажем, я хочу сделать приложение с: android:minSdkVersion="8" android:targetSdkVersion="22" Мои вопросы : Нужно ли устанавливать как «минимальную версию SDK», так и целевую версию SDK? Как если бы у меня была только версия SDK версии 23? Могу ли я сделать такую ​​настройку? Или мне нужно иметь как 22, так и 8? Могу ли я отлаживать такое приложение […]

Как проверить версию Open Mobile API на Android?

Насколько я понимаю, Open Mobile API поставляется с Android-ROM, созданным производителями. Мы используем SDK, который в значительной степени использует Open Mobile API, и выяснил, что некоторые производители создают ПЗУ, где версия Open Mobile API несовместима с версией Android. Это приводит к катастрофе, что, когда мы пытаемся использовать упомянутый SDK, приложение аварийно завершает работу. Потому что […]

Любое конкретное правило для назначения VersionName в Android?

Я обновил приложение для Android 7 раз, но до сих пор я назначаю VersionName в соответствии с моим желанием. Но теперь я хочу знать, есть ли какое-либо конкретное правило или метод для назначения VersionName для Android-приложения. Пожалуйста, дайте мне краткие сведения, если что-то есть.

Процесс обновления моего приложения на рынке

Я выпустил версию 1 на какое-то приложение на рынке. Может ли кто-нибудь сказать мне, как сообщить об этом? благодаря

Viewpager в библиотеке поддержки V13

Мое приложение широко использует компонент ViewPager, но с самого начала я использовал библиотеку поддержки V4 и даже не знал о разных версиях библиотеки. Я попрошу Android ICS как минимальную версию для запуска моего приложения, поэтому изменение на V13 не будет проблемой. Однако у меня есть сотня файлов для изменения, и мне интересно, будет ли это […]

Совместимость Open GL 2.0 vs 1.1 на Android

Привет, мы разрабатываем приложение для живых обоев для телефонов Android, наша команда кодирования говорит, что openGL 1.1 следует использовать вместо openGL 2.0. http://developer.android.com/resources/dashboard/opengl.html Это показывает, что openGL 2.0 поддерживается на 90% устройств, обращающихся к рынку, наша команда кодирования говорит, что программное обеспечение поддерживает его, но аппаратное ускорение и поддержка будут проблемой на многих устройствах с […]

Какую версию Eclipse использовать с Android?

Я старый разработчик (активный с Z80 дней), начиная с Android. На странице Android Developers рекомендуется установить Eclipse перед установкой Android SDK. В нем также говорится: «Есть известные проблемы с плагином ADT, работающим с Eclipse 3.6. Оставайтесь на 3.5 до дальнейшего уведомления». На странице загрузки Eclipse представлено 11 различных вариантов упаковки. Никто не упоминает Android, и […]

Класс нагрузки на основе версии SDK

Есть ли способ загрузить класс на основе той версии ОС, на которой работает телефон? Например: я сделал приложение, которое требует 1.6+ Android. Есть ли способ загрузить один класс или другой на основе того, на какой ОС работает телефон? Я прошу об этом специально для контактов. База данных была изменена с 1.6 до 2.0, а старая […]

Какой Android SDK я должен использовать сейчас?

Я планирую в ближайшее время попытаться запустить игру в Android Play Store, и мне было интересно, какой SDK я должен использовать сейчас? Я знаю, что для Jellybean существует 4,1, но должен ли я по-прежнему искать более старое, например, 2.2 или 2.3?

SVN-подключенный проект, не отображающий информацию о версии в eclipse

Я импортировал существующий проект из репозитория SVN, но он не будет отображать информацию о версии для элементов : Это странно для меня, потому что: Импорт прошел без ошибки, Меню Team выглядит так же, как для обычного SVN-подключенного проекта. Вот мои данные по установке :