Articles of затмение

Android: Как подключиться к проекту Eclipse Build?

Я хотел бы запустить пользовательский сценарий оболочки, щелкнув Build Project в Eclipse. Я попытался изменить раздел «компиляция» в файле build.xml, но мой скрипт не запускается. Однако вызывать ant debug в командной строке.

Ошибка установки из-за неверного файла APK! – Android

Таким образом, в этой теме было несколько сообщений, но похоже, что мой кошачий кот совершенно другой. Не уверен, что происходит. Когда я пытаюсь запустить на своем устройстве, я получаю консольный журнал: [2012-07-17 14:50:56 – zrox] Uploading zrox.apk onto device '3134F748F94100EC' [2012-07-17 14:50:56 – zrox] Installing zrox.apk… [2012-07-17 14:50:57 – zrox] Installation failed due to invalid […]

Использование сторонних библиотек в проекте android

Я только начинаю с андроида и очень быстро и быстро ищут любые учебники / ресурсы, которые могли бы ответить на мои вопросы начинающих. Как импортировать сторонний ресурс в мой проект и начать его использовать? Например, я хотел использовать scrollableTabActivity, виджет, доступный по адресу https://github.com/honcheng/ScrollableTabHost-for-Android . Я скачал, и похоже, что это проект сам по себе. […]

Eclipse продолжает развертывание устройства в режиме отладки

После развертывания на моем устройстве один раз для отладки, каждый раз, когда я пытаюсь «Run As» в обычном режиме, он все еще прикрепляет отладчик. Я удалил приложение с устройства, и он все еще делает это. Это вызывает и вызывает проблему, когда я просто хочу запустить приложение, отвязанное от моего ноутбука. Кто-нибудь еще столкнулся с этой […]

Android-приложение не запускается в симуляторе или аппаратном обеспечении

Мое приложение использовалось для запуска, но в последнее время я получаю эту нечетную ошибку: # guarantee(_name_index != 0 && _signature_index != 0) failed: bad constant pool index for fieldDescriptor Как я могу снова запустить мое приложение в симуляторе или на моем телефоне?

Подключение телефона к компьютеру приводит к зависанию Eclipse (хуже после обновления до ICS)

Когда я подключаю свой телефон к ноутбуку в режиме usb-разработчика, Eclipse зависает (затеняет), и, похоже, он должен делать что-то вроде загрузки 10 000 сообщений журнала с моего телефона. (?) Такое поведение стало намного хуже с момента обновления до ICS с пряников. И идеи? Должна быть какая-то простая настройка, которую я не понимаю. Eclipse получает паралич […]

Размер файла apk увеличился с 175 к до 1711 тыс. С небольшими изменениями – что с этим связано?

С фантастической помощью Тима на эту тему Управление Android-приложением с помощью мыши / презентатора bluetooth Я добавил Bluetooth-пульт дистанционного управления своим приложением. Закончив это, я заметил, что мой файл apk пошел от 175k до 1711k – в 10 раз больше! Я реализовал изменения bluetooth в тестовом приложении, не видя никаких изменений в размере файла, поэтому […]

Ant не может импортировать R.java

Я работаю над файлом сборки муравьев (отдельно от eclipse) для создания моего приложения для Android. Мне нужно сгенерировать файл R.java. Я сделал это успешно, однако, когда он пытается построить мой проект из каталога src он жалуется, что не может найти импортированный файл R.java. Я вижу это в каталоге gen … но он все равно не […]

Eclipse не отображает время в logcat только для галактики nexus?

Я использую Galaxy nexus с Jelly bean, и я заметил, что logcat не отображает время. Я также заметил, что он не применяет фильтры для Galaxy Nexus. Он также не показывает исключений красного цвета. ?:??: W/?(?): [ 07-16 10:31:42.153 462: 462 D/PhoneStatusBar ] ?:??: W/?(?): disable: < expand icons alerts ticker system_info back home RECENT* clock […]

Проблема с конфигурацией Android в Eclipse

Когда я вхожу на сайт ниже https://dl-ssl.google.com/android/eclipse/ В окне « Install new software он найдет инструменты для разработчиков Android. Когда я проверяю все и ударяю, он показывает ошибку ниже, и ADT не устанавливается. Cannot complete the request. See the details. Unsatisfied dependency: [com.android.ide.eclipse.hierarchyviewer.feature.group 10.0.1.v201103111512-110841] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.runtime/3.5.0 Unsatisfied dependency: [com.android.ide.eclipse.traceview.feature.group 10.0.1.v201103111512-110841] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.runtime/3.5.0 Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group […]

Intereting Posts