Intereting Posts
Изменение размера растрового изображения в Android Ароматы подписи под ключ с разными клавишами на Android Eclipse зависает в DDMS после создания init Как использовать Android Spinner как раскрывающийся список Android: какая разница между setFlags и addFlags для намерения Могу ли я копировать между CouchBase на Android и Couch DB, работающим в Linux? Android studio 2.3 canary отсутствует опция «Запустить автономный SDK-менеджер» в «SDK Manager» TextView подчеркивает номер телефона и гиперссылку Почему класс фрагмента может быть недействительным? Что вызывает сообщение «Включить конвертер myanmar Zawgyi», Публикация приложения PAID на рынке Android – Индия Как добавить библиотеки Android с ресурсами без использования Eclipse OnLoadFinished не вызывается после возврата из кнопки HOME нажмите Отключение многооконной функции для Android N, не работающей на активность Почтовый многопользовательский запрос с Android SDK

Ошибка студии Android Эта библиотека поддержки не должна использовать более низкую версию (19)

Я создал проект, затем сообщение об ошибке:

Error:(23, 12) This support library should not use a lower version (19) than the targetSdkVersion (20) 

Код ошибки: compile 'com.android.support:appcompat-v7:19.+'

Solutions Collecting From Web of "Ошибка студии Android Эта библиотека поддержки не должна использовать более низкую версию (19)"

+ Изменить

 compile 'com.android.support:appcompat-v7:19.+' 

в

 compile 'com.android.support:appcompat-v7:20+' 

Сначала откройте SDK Manager и обновите поддержку Libary. Или изменить targetSDKVersion на 19

Имя файла – 'build.gradle'

Перейдите в Инструменты -> Android -> Менеджер SDK -> вкладка SDK Tools -> Библиотека поддержки Android -> посмотрите версию

Затем перейдите в Project view -> YourProject -> app -> build.gradle -> change

 compile 'com.android.support:appcompat-v7:19.+' 

в

 compile 'com.android.support:appcompat-v7:yourLatestVersion' 

Версия библиотеки поддержки Android должна быть заменена на последнюю версию, имеющуюся в вашем SDK. Обратите внимание, что ваша targetSDKVersion должна быть такой же, как com.android.support:appcompat-v7:Version .