Intereting Posts
Рамки, обнаруженные в студии Android Хорошие рекомендации по разработке приложения для электронной торговли Как узнать номер SimSlot для каждого Call / sms? Android Изменение экрана в режиме ожидания через AOSP Android – обновить растровое изображение по таймеру Android Media Player не будет воспроизводиться после остановки Android AsyncTask возвращает несколько значений в doInBackground, которые будут использоваться для onPostExecute Java вычисляет время между двумя временными метками Можно ли использовать переднюю и заднюю камеры одновременно в Android Как найти использование памяти моего приложения для Android, написанного на C ++, с использованием NDK Исходное приложение для Android Studio static = libcore.io.Posix ENOENT Отображение общего доступа Android на других устройствах Viewpager не обертывает содержимое после загрузки изображений из Интернета Список ActionBar Перемещение перекрывающих фрагментов Как добавить логотип в экран согласия Google?

Android.support.v7.widget.CardView не удалось найти (Android Studio 1.1 Preview)

Введите описание изображения здесь

Я пытаюсь добавить CardView в свою деятельность в качестве официального образца. Но это не сработает.

Если я запускаю свой проект напрямую, это приведет к java.lang.ClassNotFoundException: android.support.v7.widget.CardView.

Solutions Collecting From Web of "Android.support.v7.widget.CardView не удалось найти (Android Studio 1.1 Preview)"

Вы должны добавить его в свой build.gradle :

 dependencies { ... compile 'com.android.support:cardview-v7:21.+' compile 'com.android.support:recyclerview-v7:21.+' ... } 

Напиши свой ответ, чтобы предоставить:

1) обновленная строка «compile» для compileSdkVersion 25

2) полный номер версии, чтобы прислушаться к «Избегайте использования + в номерах версий, может привести к непредсказуемым и неповторимым сборкам ..», предупреждение, показанное Android Studio

3) Предоставление визуальной информации о местоположении «build.gradle (Module: app)»

4) Потому что я не могу написать комментарий ниже ответа @ Eun [stackoverflow не позволяет мне]

Вам нужно вставить следующее в build.gradle [Module: app], расположенное по адресу:
(Например, с помощью диспетчера файлов) MyFirstApplication -> app -> build.gradle

Compile 'com.android.support:cardview-v7:25.3.1'

Вам нужно вставить его в следующее условие зависимостей:

 dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) ... compile 'com.android.support:appcompat-v7:25.3.1' compile 'com.android.support:cardview-v7:25.3.1' ... } 

Открыть с самой студии Android:
«1: Проект» (слева) -> Выберите «Android» -> «Сценарии градиента» -> «build.gradle (Module: app)» [Это второй файл сверху … внутри сценариев Gradle]

То есть:
(Если изображение ниже не показано, вы можете найти изображение здесь.

Использование Android Studio 2.3.1

Изменить : обновленные номера версий