Ошибка зависимостей android-support-v4.jar

Я только что создал новый пустой проект Android с minsdk как 2.2 в последнем Eclipse Luna.Eclipse автоматически добавил android-support--v4.jar в папку libs проекта. Это вызывает ошибку в консоли:

 Found 2 versions of android-support-v4.jar in the dependency list, but not all the versions are identical (check is based on SHA-1 only at this time). All versions of the libraries must be the same at this time. Versions found are: Path: /home/faizal/DEV/ADT workspace/myNewProject/libs/android-support-v4.jar Length: 758727 SHA-1: efec67655f6db90757faa37201efcee2a9ec3507 Path: /home/faizal/DEV/ADT workspace/appcompat_v7/libs/android-support-v4.jar Length: 648327 SHA-1: ded9acc6a9792b8f1afc470f0c9cd36d178914cd Jar mismatch! Fix your dependencies 

Это связано с тем, что у меня также есть проект библиотеки поддержки appcompat_v7, который я использую для другого проекта и был создан старым Eclipse (я думаю, что это был Juno .. он был частью пакета ADT).

Я знаю, что решение состоит в том, чтобы удалить одну из банок, но какой и почему?

Solutions Collecting From Web of "Ошибка зависимостей android-support-v4.jar"

Вам просто нужно:

  1. Щелкните правой кнопкой мыши проект myNewProject
  2. Перейдите в «Инструменты Android»> «Добавить библиотеку поддержки»
  3. Утвердить разрешения и обновить библиотеку
  4. Повторите этот процесс для проекта appcompat_v7

Библиотека поддержки Android будет синхронизирована (:

Вы импортируете библиотеку appcompat_v7, у которой также есть поддержка android-v4.jar, но разный размер. Просто скопируйте поддержку android-v4.jar из вашей библиотеки проектов в папку appcompat_v7. Пути папок находятся в вашем посте, просто для информации.

  1. Щелкните правой кнопкой мыши проект demoProject
  2. Перейдите в «Инструменты Android»> «Добавить библиотеку поддержки»
  3. Утвердить разрешения и обновить библиотеку
  4. Повторите этот процесс для проекта appcompat_v7 (или любой библиотеки
  1. Посмотрите на пути несоответствий
  2. Удалите файл в папке проекта> libs
  3. Скопируйте файл из папки appcompat libs в папку проекта libs
  4. Закрыть и снова открыть Eclipse
  5. Чистый проект