Intereting Posts
Android 2.3 и API google maps v2 Какова максимальная длина имени приложения для Android? Android GoogleMap или SupportMapFragment – исключение нулевого указателя Каков оптимальный способ совместного использования кода между действиями с различными базовыми классами? Как увидеть источник или javadocs для зависимости от библиотеки в пакете Android в Eclipse? Приложение для закрытых пользовательских карт Как получить значения атрибутов темы AsyncTask, Фрагменты, Представления и Backstacks Как я могу сделать вибрационную анимацию для ImageView Статические методы против расширения класса android.app.Application? Передача данных между Android BroadcastReceiver, ContentProvider и Activity? Как определить, когда пользователь запускает другое приложение? (Android) Фиксированные значения графика Android на x угол Рассчитать Pi на телефоне Android Могу ли я запускать мягкую клавиатуру Android для открытия через javascript (без телефонного разговора)?

Не удалось найти класс android.support.v4.app.NotificationCompat $ Builder

Сегодня у меня странная ошибка, странная, потому что приложение работает день назад, и я ничего не меняю, я также обновил Android SDK и eclipse.

05-20 08: 03: 14.217: E / AndroidRuntime (1925): java.lang.NoClassDefFoundError: android.support.v4.app.NotificationCompat $ Builder

05-20 08: 03: 15.918: E / dalvikvm (1716): Не удалось найти класс 'android.support.v4.app.NotificationCompat $ Builder', на который ссылается метод com.me.app.ObjReminder.setNotification

Почему у меня такая ошибка? Как я могу это решить?

EDIT: Спасибо всем, я решил проверить «частные библиотеки Android» на вкладке «Заказ и экспорт». Но я не понимаю, почему проверка исчезла

Когда мы обновляем наш SDK, поддержка по умолчанию api автоматически обновляется.

Таким образом, предыдущая поддерживаемая библиотека поддержки будет обманута.

Вам просто нужно открыть свойства проекта и обновить ссылки на библиотеки.