Intereting Posts
Установите разрешение «разрешить» по умолчанию в «Автозагрузке Asus» из кода Как создать стиль приложения Twitter. Быстрые действия на Android Можно ли сжимать видео на Android? Android ImageView.setMatrix () и .invalidate () – перекраска занимает слишком много времени Как использовать onConfigurationChanged () и newConfig.orientation == Configuration.ORIENTATION_LANDSCAPE в android 2.3.3 Какие версии GLSL можно использовать в OpenGL ES 2.0? Является ли идентификатор устройства Android Android когда-либо измененным? Android.app Fragments vs. android.support.v4.app с помощью ViewPager? Функциональность TextureView в Android до 4.0? Примеры использования Square Flow + Mortar Как нарисовать круг после увеличения в андроиде Android SharedPreferences в фрагменте Как запустить службу FCM ID только после того, как будет запущено определенное действие? Как открыть меню Контекст Android с кнопкой щелчка в адаптере listview? Ошибка студии Android Эта библиотека поддержки не должна использовать более низкую версию (19)

Android Studio – с Junit 4.12 "!!! Ожидается, что версия JUnit версии 3.8 или более поздней версии:

Пробовал предложения на этом посту, но я все равно получаю сообщение об ошибке:

!!! JUnit version 3.8 or later expected: java.lang.RuntimeException: Stub! at junit.runner.BaseTestRunner.<init>(BaseTestRunner.java:5) at junit.textui.TestRunner.<init>(TestRunner.java:54) at junit.textui.TestRunner.<init>(TestRunner.java:48) at junit.textui.TestRunner.<init>(TestRunner.java:41) Process finished with exit code -3 

Не уверен, что делать дальше. Попытка реорганизации порядка зависимости Junit. Не повезло, кто-нибудь еще получил эту проблему?

Android Studio V. 1.2.1.1

Solutions Collecting From Web of "Android Studio – с Junit 4.12 "!!! Ожидается, что версия JUnit версии 3.8 или более поздней версии:"

Решил проблему. Я запускал тесты JUnit в качестве стандартного «теста JUnit» в Android Studio . Я исправил проблему, сбросив конфигурацию в качестве Android Test на Android Test .

Я решаю эту проблему, перемещая «testCompile» junit: junit: 4.12 '"в первый порядок в блоке зависимости build.gradle

Запустив это, вы открываете старый проект в последнюю версию Android Studio 2.3 после автоматического обновления проекта.

Android Studio поддерживает тесты Android JUnit, которые должны запускаться с использованием текущего JRE хоста и надлежащим образом поддерживать JUnit 4+. Ошибка связана с неправильным использованием JRE.

С помощью Edit Configuration> выберите конфигурацию Android JUnit> отредактируйте JRE. Выберите любой вариант, используйте «Применить», а затем верните его в «Default (Android Platform)», чтобы он работал.

В моем случае я просто забыл, что я изменил вариант сборки на «release». Переключение на «отладка» исправлено. FML.