Intereting Posts
System.lineSeparator () не существует в android Admob Interstitial загружает, но показывает пустой экран GetDefaultTracker () из класса, который расширяет InputMethodService? Определение политики SELinux для системного сервиса Android: как настроить? Как я могу отправить исключение вручную с помощью Crittercism? Почему ImageView.setImageURI () работает в Android 2.2, но не 2.1? Обрабатывать существующий экземпляр корневой активности при повторном запуске корневой активности из фильтра намерений Невозможно перенести данные из приложения в mysql с помощью localhost Поиск кросс-платформенного метода для базовой 2D / 3D графики для iOS и Android HttpUrlConnection.getInputStream возвращает пустой поток в Android Где находится ключ подписи android на диске, который создает Xamarin Studio? Try catch всегда возвращает null Seekbar для двух значений Поддержка Android BottomSheetBehavior не может быть динамической? Как заставить FrameLayout заполнить высоту своего родителя, чтобы вся страница прокручивалась вместе?

Android Studio – невозможно создать проект – GradleConnectionException

Я на Android Studio 0.3.2. Поскольку я обновил предыдущую версию, не удалось создать существующие проекты.

Я постоянно сталкиваюсь с проблемами интеграции градиентов. Я трачу больше времени на сортировку градиента, чем на любой код. Я был в тупике уже неделю!

Я получаю ошибку, упомянутую на стольких сообщениях, но после прочтения часами ни одно из решений не сработало для меня.

Org.gradle.tooling.GradleConnectionException: Не удалось выполнить сборку с использованием установки Gradle 'C: \ Users \ Adrian.gradle \ wrapper \ dists \ gradle-1.8-all \ 2kopnp0i5dq014k75fp36m3vd5 \ gradle-1.8' .: Не удалось выполнить сборку с использованием установки Gradle 'C: \ Users \ Adrian.gradle \ обертка \ dists \ Gradle-1,8-все \ 2kopnp0i5dq014k75fp36m3vd5 \ Gradle-1,8'.

Я проверил мою версию градиента, используя встроенное окно терминала в студии Android.

Gradlew --version в окне терминала

Мой gradle.xml

<?xml version="1.0" encoding="UTF-8"?> <project version="4"> <component name="GradleSettings"> <option name="linkedExternalProjectsSettings"> <GradleProjectSettings> <option name="distributionType" value="DEFAULT_WRAPPED" /> <option name="externalProjectPath" value="$PROJECT_DIR$" /> <option name="useAutoImport" value="true" /> </GradleProjectSettings> <GradleProjectSettings> <option name="distributionType" value="DEFAULT_WRAPPED" /> <option name="externalProjectPath" value="D:\Users\Adrian\AndroidStudioProjects\SupaScaleProject" /> <option name="useAutoImport" value="true" /> </GradleProjectSettings> </option> <option name="serviceDirectoryPath" value="$USER_HOME$/.gradle" /> </component> </project> 

Мои параметры gradle-wrapper.properties

 distributionBase=GRADLE_USER_HOME distributionPath=wrapper/dists zipStoreBase=GRADLE_USER_HOME zipStorePath=wrapper/dists distributionUrl=http\://services.gradle.org/distributions/gradle-1.8-all.zip 

Мой build.gradle

 buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.6.+' } } apply plugin: 'android' repositories { mavenCentral() } android { compileSdkVersion 18 buildToolsVersion "18.1.1" defaultConfig { minSdkVersion 14 targetSdkVersion 18 } buildTypes { release { runProguard true proguardFile getDefaultProguardFile('proguard-android-optimize.txt') } debug { runProguard false proguardFile getDefaultProguardFile('proguard-android-optimize.txt') } } } dependencies { compile 'com.android.support:support-v4:13.0.+' compile files('libs/achartengine-1.1.0.jar') } 

Я делаю сборку из терминала: gradlew compileDebug и сборка выполнена успешно!

Введите описание изображения здесь

Теперь я создаю форму в строке меню Build -> Rebuild Project (в AndroidStudio 0.3.2):

Введите описание изображения здесь

Я действительно не знаю, где искать. Любая помощь будет оценена по достоинству.

О … да, я удалил все файлы в .gradle / wrapper / dists / и разрешил загрузку Android Studio для меня.

Заранее спасибо.

Адриан

После комментария @joucks я заметил следующее на http://tools.android.com/knownissues :

Введите описание изображения здесь

Поэтому я изменил свой build.gradle на classpath 'com.android.tools.build:gradle:0.6.3' к сожалению, все тот же результат.

После этого я обновил compileSDKVersion до 19 и buildToolsVersion до «19.0.0», надеясь на некоторый успех. К сожалению, нет. Да … и прежде чем вы спросите, мой SDK-менеджер обновлен со всеми последними файлами.

Я, наконец, понял это. Оба раза это случилось со мной, перезагрузка моего компьютера заставила его уйти. «GradleConnectionException» должно произойти из-за некоторой утечки памяти или проблемы с ресурсами в окнах.

Чтобы процитировать заметки о выпуске Android Studio 0.3.2 и подробные сведения :

Вам также необходимо убедиться, что Gradle использует версию 1.7 или новее JDK. (И версия 0.6.1 или новее плагина Android Gradle.)

И вы используете classpath 'com.android.tools.build:gradle:0.6.+' . Это может быть связано.

Отметьте это сообщение: https://plus.google.com/+AndroidDevelopers/posts/1RcQews58tB Несколько ребята сообщают, что удаление папок gradle-1.8 и .gradle, похоже, устраняет проблему. Кроме того, насколько я помню, проблема может повториться, если есть проблемы с нехваткой памяти.

Редактировать:

Это поток: http://code.google.com/p/android/issues/detail?id=61259

В моем случае, после down-grading jdk от 1.7 u51 до 1.7 u45, все работает нормально.

Я предполагаю, что gradle 1.8 проверяет номер версии JDK.