Ошибка сборки Android Studio Gradle при добавлении Facebook SDK

Привет, я получаю следующую ошибку при добавлении facebook sdk к моему проекту. Пробовал следующую запись для настройки сценария градиента для facebook sdk

ссылка

Error:(111) A problem occurred evaluating project ':facebook'. > Cannot call getBootClasspath() before setTargetInfo() is called. 

Это мой скрипт градиента модуля facebook

 apply plugin: 'com.android.library' repositories { mavenCentral() } project.group = 'com.facebook.android' dependencies { compile 'com.android.support:support-v4:[21,22)' compile 'com.parse.bolts:bolts-android:1.1.4' } android { compileSdkVersion 22 buildToolsVersion "22.0.0" defaultConfig { minSdkVersion 18 targetSdkVersion 22 } lintOptions { abortOnError false } sourceSets { main { manifest.srcFile 'AndroidManifest.xml' java.srcDirs = ['src'] res.srcDirs = ['res'] } } } apply plugin: 'maven' apply plugin: 'signing' def isSnapshot = version.endsWith('-SNAPSHOT') def ossrhUsername = hasProperty('NEXUS_USERNAME') ? NEXUS_USERNAME : "" def ossrhPassword = hasProperty('NEXUS_PASSWORD') ? NEXUS_PASSWORD : "" task setVersion { // The version will be derived from source project.version = null def sdkVersionFile = file('src/com/facebook/FacebookSdkVersion.java') sdkVersionFile.eachLine{ def matcher = (it =~ /(?:.*BUILD = \")(.*)(?:\".*)/) if (matcher.matches()) { project.version = matcher[0][2] return } } if (project.version.is('unspecified')) { throw new GradleScriptException('Version could not be found.', null) } } uploadArchives { repositories.mavenDeployer { beforeDeployment { MavenDeployment deployment -> signing.signPom(deployment) } repository(url: "https://oss.sonatype.org/service/local/staging/deploy/maven2/") { authentication(userName: ossrhUsername, password: ossrhPassword) } snapshotRepository(url: "https://oss.sonatype.org/content/repositories/snapshots/") { authentication(userName: ossrhUsername, password: ossrhPassword) } pom.project { name 'Facebook-Android-SDK' artifactId = 'facebook-android-sdk' packaging 'aar' description 'Facebook Android SDK' url 'https://github.com/facebook/facebook-android-sdk' scm { connection 'scm:git@github.com:facebook/facebook-android-sdk.git' developerConnection 'scm:git@github.com:facebook/facebook-android-sdk.git' url 'https://github.com/facebook/facebook-android-sdk' } licenses { license { name 'The Apache Software License, Version 2.0' url 'https://github.com/facebook/facebook-android-sdk/blob/master/LICENSE.txt' distribution 'repo' } } developers { developer { id 'facebook' name 'Facebook' } } } } } uploadArchives.dependsOn(setVersion) signing { required { !isSnapshot && gradle.taskGraph.hasTask("uploadArchives") } sign configurations.archives } task androidJavadocs(type: Javadoc) { source = android.sourceSets.main.java.srcDirs classpath += project.files(android.getBootClasspath().join(File.pathSeparator)) } task androidJavadocsJar(type: Jar, dependsOn: androidJavadocs) { classifier = 'javadoc' from androidJavadocs.destinationDir } task androidSourcesJar(type: Jar) { classifier = 'sources' from android.sourceSets.main.java.sourceFiles } artifacts { archives androidSourcesJar archives androidJavadocsJar } afterEvaluate { androidJavadocs.classpath += project.android.libraryVariants.toList().first().javaCompile.classpath } 

Пожалуйста помоги….

Ваша проблема: Cannot call getBootClasspath() before setTargetInfo() is called. , Я считаю, что здесь было решено:

http://tools.android.com/tech-docs/new-build-system

Инструменты Android Build 1.1.0 создали эту проблему, и они установили ее в 1.1.1 :

1.1.1 (2015/02/24)

  • Только варианты, которые упаковывают приложение Wear, теперь будут запускать их.

  • Проблемы, связанные с зависимостью, теперь терпят неудачу во время сборки, а не во время отладки.

  • Это позволяет запускать диагностические задачи (например, «зависимости») для разрешения конфликта.

  • Вызов android.getBootClasspath () теперь возможен снова.

Обновите страницу: classpath 'com.android.tools.build:gradle:1.2.3' , например:

 buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:1.2.3' } }