Intereting Posts
Внедрить безопасность на уровне подписки на услуги Android с более чем одной разрешенной подписью Как открыть сайт при нажатии кнопки в приложении Android? Управление фонариком в Зефир Как закодировать звук без пробелов в Android? Общие настройки против базы данных Полезно ли использовать библиотеку Google Guava для разработки Android? Заполнять Spinner динамически в android из текста редактирования Android Google Analytics, вызывающая черный экран Отправка электронной почты на Android с использованием API JavaMail без использования стандартного / встроенного приложения Как установить расширенные пользовательские атрибуты в файлах Android? Как заполнить столбец «Приложение» в LogCat (Android-14 +) Как установить SELinux в 0 или разрешающий режим в android 4.4.4 и выше? Чтение двоичных данных stdout из оболочки adb? Обновление Android Studio 2.0 – общедоступный статический volatile com.android.tools.fd.runtime.IncrementalChange Как установить рингтон с RingtoneManager.ACTION_RINGTONE_PICKER?

Android Studio – Gradle

Я пытаюсь использовать новейшую версию gradle для студии Android, которая составляет 1.3.0.

http://android-developers.blogspot.ro/2015/07/get-your-hands-on-android-studio-13.html

К сожалению, у меня возникают проблемы при попытке обновить версию gradle. Предыдущая версия gradle была 1.2.3 и теперь хотела обновить ее до 1.3.0.

Я получаю следующую ошибку:

Error:Cannot access first() element from an empty List 

Я также обновился до Android Studio 1.3, и в настоящее время я использую следующие инструменты сборки:

 buildToolsVersion "23.0.0 rc3" 

Я попытался удалить градир и .gradle dirs из моего проекта, а также файл .gradle из домашней директории пользователя, но без успеха.

Даже я попытался перейти в File -> Invalidate cache / restart, но все равно никакого решения.

Solutions Collecting From Web of "Android Studio – Gradle"

У меня была такая же проблема с использованием gradle 1.3.1 и buildtools 23.0.1. Я обнаружил, что это произошло из-за старой версии bintray-release. Эта проблема исправлена ​​в версии 0.3.4+.

 classpath 'com.novoda:bintray-release:0.3.4' 

Я получаю сообщение об ошибке « Ошибка: не удается получить доступ к элементу first () из пустого списка» при компиляции образца проекта «Drive Database Sync» на git.

Решение: проблема возникла из-за версии bintray, и я решил проблему, используя следующий gradle.build –

 // Top-level build file where you can add configuration options common to all sub-projects/modules. buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:2.0.0' classpath 'com.novoda:bintray-release:0.3.4' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { jcenter() } }