Intereting Posts
RecyclerView, StaggeredGridLayoutManager Обновить ошибку Android LinearLayout: добавьте границу с тенью вокруг линейногоLayout Программно вернуться к предыдущему фрагменту в стопке Получить самую высокую скорость обновления GPS от оборудования GPS в моем Android Как вернуть результат деятельности Child в Parent в android? Почему я должен использовать фрагмент в Android? Как избавиться от пробелов в gridview Использование курсора в android Как решить «Код версии вашего APK должен быть выше 2.» в консоли разработчика Google Play? ActionBar / панель инструментов не отображается в версии приложения Lollipop Различные регулярные выражения приводят к платформе Java SE и Android Можно ли отключить доступ к макету (представлениям) фрагмента из родительской активности? Вертикально-полосатый фон в XML? Как добавить две новые колонки для Android SQLite Database? GlDepthMask (GL_FALSE) удаляет буфер кадра на некоторых графических процессорах

Android Studio 3.0 canary – Не удалось разрешить: org.apache.httpcomponents: httpclient: 4.0.1

Я установил AS 3.0 Canary, импортировал существующий проект, и во время выполнения синхронизации града я получил эту ошибку:

Failed to resolve: org.apache.httpcomponents:httpclient:4.0.1 

Я попробовал очистить проект, и это тоже не удалось. Это было частью ошибки:

 Required by: project :app > com.google.api-client:google-api-client-android:1.22.0 > com.google.http-client:google-http-client-android:1.22.0 > com.google.http-client:google-http-client:1.22.0 

Я посмотрел на другие вопросы, и похоже, что httpclient устарел в API 23. Но каждое решение, представленное в этих вопросах, похоже, не работает.

Что еще более сбивает с толку, так это то, что он отлично targetSdkVersion с AS 2.4 Preview 7, а targetSdkVersion и compileSdkVersion 25.

Изменить: я пытался запустить его на стабильной версии AS, и, похоже, он работает нормально. Но мне нужны новые эмуляторы в версиях предварительного просмотра.

Solutions Collecting From Web of "Android Studio 3.0 canary – Не удалось разрешить: org.apache.httpcomponents: httpclient: 4.0.1"

У меня такая же проблема. Поместив это в файл build.gradle модуля, на корневом уровне, исправлена ​​эта ошибка.

 configurations { compile.exclude group: "org.apache.httpcomponents", module: "httpclient" } 

Была та же проблема. Заканчивается исключение «org.apache.httpcomponents», в моем случае, из «com.google.http-client: google-http-client: 1.21.0».

До:

 compile 'com.google.http-client:google-http-client:1.21.0' 

После:

 compile ('com.google.http-client:google-http-client:1.21.0') { exclude group: 'org.apache.httpcomponents' }