Intereting Posts
Как предотвратить открытие клавиатуры при открытии активности в Android? Как настроить значок стрелки, значок страницы и заголовок страницы в MasterDetailPage – Xamarin.Forms Нет файлов сгенерированных Dagger2 для тестов JUnit Селектор диапазона / диапазон поиска для обрезки видео, включая эскизы Что такое код приложения, используемый для создания ссылки URL глубокой ссылки в Firebase для Android Android: конвертация 'dp' в 'px'? Настройка цвета фона для SurfaceView в Android Получить последний загруженный URL-адрес веб-обозревателя без использования webView.goBack () в Android Android: сохранить объект android.net.Uri в базу данных Снек-бар не отображается Как играть или возобновлять музыку другого музыкального проигрывателя из моего кода? Как включить / отключить 3G / 2G в Android SDK Как сделать диалоговое окно edittext в диалоговом окне Android Frame by Frame Анимация проблемы на элементах в CursorAdapter Android Назад к первому фрагменту в навигационном устройстве

В Android Studio 2.1.3 экспериментальная градация не работает?

У меня есть проект, в котором я смешиваю и поддерживаю обычный Android Gradle Plugin:

apply plugin: 'com.android.library' 

И экспериментальный Gradle Plugin в качестве библиотеки:

 apply plugin: 'com.android.model.library' 

В моем общем build.gradle у меня есть следующие зависимости:

 buildscript { repositories { jcenter() } dependencies { classpath 'com.google.gms:google-services:3.0.0' classpath 'com.android.tools.build:gradle-experimental:0.7.2' classpath 'com.android.tools.build:gradle:2.1.3' } } 

И теперь, после обновления до Android 2.1.3, я получаю следующую ошибку сразу после Gradle Sync:

Не удалось синхронизировать Gradle: требуется Gradle версия 2.10. Текущая версия> 2.14.1. Если вы используете оболочку градиента, попробуйте отредактировать дистрибутивUrl в?> Blah blah blah

В это время. В журнале IDE Android IDE я вижу следующую ошибку:

Вызвано: org.gradle.api.internal.plugins.PluginApplicationException:> Не удалось применить плагин [class> 'com.android.build.gradle.model.AndroidComponentModelPlugin']

Когда я исправляю файл gradle-wrapper.properties, я получаю следующее после Gradle Sync:

Ошибка: Минимальная поддерживаемая версия Gradle – 2.14.1. Текущая версия> 2.10. Если вы используете оболочку gradle, попробуйте отредактировать дистрибутивUrl в> / Users / development / Desktop / android_msdk / xFAClient / Android / xFA / gradle / wrapp> er / gradle-wrapper.properties до gradle-2.14.1-all.zip

И снова и снова …

У меня нет подсказки здесь …

Обновление экспериментальной градиентности до 0,7:

  classpath 'com.android.tools.build:gradle-experimental:0.7.3' 

Это позволяет совместимость с оболочкой градиента 2.14.1.