Эмулятор не работает в Android Studio 2.0

Я использую версию Android Studio 2.0 Stable. Всякий раз, когда я нажимаю кнопку воспроизведения на устройстве, чтобы ее запускать, он показывает начало AVD-прогресса в студии android, и после завершения его прогресса ничего не произошло. Окно приложения остается таким, как показано на скриншоте, и эмулятор не запускается. Я не могу найти решение этой проблемы. Я уже пробовал много решений, которые я нашел в Интернете, изменив версию HAXM android SDK, изменив целевой API. Но ничего не работает.

1

Попробуйте отредактировать настройки AVD -> Emulated Performance -> Graphics. Комплект программного обеспечения – GLES 2.0.

У меня была такая же проблема.

Windows 7 Professional SP1. Установленный Android Studio 2.0, новый HAXM ver 6.0.1 и обновленный для всех новых компонентов, таких как инструменты SDK 25.1.1.

При запуске – эмулятор не отображает ни одного окна. «Emulator.exe» запускается в диспетчере задач и потребляет 25% процессора.

Удалены все AVD, повторно созданы новые; Использовал AVD Manager напрямую; Используемые изображения ARM / Atom (с / без HAXM); Попробовал AVD с различным уровнем API – ничего не помогает.

Возвращение в Android SDK Tools 24.4.2 помогает – я могу запускать эмулятор, как обычно, – так, похоже, это не проблема нового HAXM 6.0.1.

Последневная борьба наконец-то получила разрешение:

Я удалил C: Windows \ System32 \ Wbem из переменной системы PATH .

У меня такая же проблема. Я только что создал AVD с RAM 768 МБ, и все получилось нормально!

У меня такие же проблемы, как и вы. Я обновил Android Studio до версии 2.0, которая также обновила Android SDK.

Я считаю, что эта проблема связана скорее с проблемой Android SDK, поскольку я напрямую использую AVD Manager SDK. Я могу воспроизвести эту проблему.

В качестве другой точки данных я также модифицировал виртуальное устройство, чтобы использовать только 768 МБ ОЗУ, без каких-либо последствий. Диспетчер задач показывает эмулятор, используя 2 потока и 13% CPU, независимо от того, как долго я его покидаю, но никогда не появляется окно. Я пробовал с и без HAXM. Мои виртуальные устройства работают на уровне API 21 (x86_64) и 19 (x86).

Я также переустановил Android Studio и Android SDK без каких-либо изменений. Это может быть проблема конфигурации из-за обновления 2.0 и SDK, сломанной версии SDK или чего-то еще.

Возврат к Android SDK 24.4.1 позволяет эмулятору снова работать, но без функции 25.1.1.

  1. Открыть cmd
  2. Type set и проверьте, можете ли вы увидеть C:\Windows\System32\Wbem в переменной PATH

  3. Перейдите в Панель управления -> Система (слева) -> Расширенные настройки системы -> (кнопка внизу) Переменные среды

    Либо в пользовательских переменных (или, скорее, системных переменных) в переменной PATH remove

     %SystemRoot%\System32\Wbem (or C:\Windows\System32\Wbem) 
  4. Перезапустить студию

Установка эмулятора Android (помеченная на изображение) решила мою проблему. Если вы все еще сталкиваетесь с проблемой проблемы с установкой API-интерфейса API и эмулятором DHU. Но только AE решит проблему, я думаю. Введите описание изображения здесь

Я наткнулся на ту же проблему. Я проверил менеджера SDK, выяснилось, что эмулятор не установлен. После того, как он будет установлен, эмулятор начнет показывать