С включенным эмулятором Android Snapshot

Два дня назад я установил все обновления Android SDK. Раньше у меня было 2.2 API 8, версия 2. После обновления я включил моментальный снимок – я не могу запустить эмулятор с включенным моментальным снимком. Я получаю это сообщение (красным) в консоли
NAND: nand_dev_load_disk_state ftruncate failed: неверный аргумент

Я получаю это сообщение в logcat почти каждые 5 секунд
03-03 19: 45: 38.008: WARN / MountService (59): слишком долго ждать mReady!

Трассировка до появления этого сообщения показана ниже

03-03 19:39:56.633: INFO/SystemServer(59): Mount Service 03-03 19:39:56.672: INFO/SystemServer(59): Notification Manager 03-03 19:39:56.722: INFO/SystemServer(59): Device Storage Monitor 03-03 19:39:56.752: ERROR/VoldConnector(59): No connection to daemon 03-03 19:39:56.752: ERROR/VoldConnector(59): java.lang.IllegalStateException 03-03 19:39:56.752: ERROR/VoldConnector(59): at com.android.server.NativeDaemonConnector.sendCommand(NativeDaemonConnector.java:191) 03-03 19:39:56.752: ERROR/VoldConnector(59): at com.android.server.NativeDaemonConnector.sendCommand(NativeDaemonConnector.java:178) 03-03 19:39:56.752: ERROR/VoldConnector(59): at com.android.server.NativeDaemonConnector.doCommand(NativeDaemonConnector.java:213) 03-03 19:39:56.752: ERROR/VoldConnector(59): at com.android.server.NativeDaemonConnector.doListCommand(NativeDaemonConnector.java:258) 03-03 19:39:56.752: ERROR/VoldConnector(59): at com.android.server.MountService$2.run(MountService.java:425) 03-03 19:39:56.783: INFO/SystemServer(59): Location Manager 03-03 19:39:56.793: INFO/SystemServer(59): Search Service 03-03 19:39:56.802: INFO/SystemServer(59): DropBox Service 

Может кто-нибудь, пожалуйста, скажите мне, что может быть неправильно с моей настройкой? Я прилагаю скриншот установленных пакетов.

Введите описание изображения здесь

Эмулятор не запускается, я должен его убить и перезапустить eclipse с отключенным снимок. http://tools.android.com/recent/emulatorsnapshots

С отключенным снимок – вот что такое logcat

 03-04 04:17:41.387: INFO/SystemServer(73): Device Storage Monitor 03-04 04:17:41.398: INFO/PackageManager(73): Updating external media status from unmounted to unmounted 03-04 04:17:41.407: DEBUG/VoldCmdListener(29): share status ums 03-04 04:17:41.457: INFO/SystemServer(73): Location Manager 

Платформа AVD – 2.2 / API 8
спасибо

@Greg
Вот подробности для AVD
Введите описание изображения здесь

Попробуйте удалить SD-карту и посмотреть, работает ли она.

Вот что я сделал и результат: в AVD-менеджере отредактируйте avd, есть опции эмуляции, снимите флажок «Снимок». (Я забыл, почему я выбрал его, но я думаю, что снимок отсутствует и вызывает ошибку.) И он работает. Надеюсь, поможет.