Android sdk требует инструментария разработчика Android версии 22.6.1 или выше

ADT открывается с сообщением об ошибке:

«Андроид SDK требует ADT версии 22.6.1 или выше»

Не удалось выполнить следующие подходы к обновлению ADT:

  1. Использование диспетчера SDK для обновления плагинов ADT
  2. Перейти в Help-> Установить новое программное обеспечение -> выбрать сайт разработчиков Android -> обновить инструменты для разработчиков

Сбой на установку нового программного обеспечения:

An error occurred while collecting items to be installed session context was:(profile=profile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=). No repository found containing: osgi.bundle,com.android.ide.eclipse.adt,22.6.0.v201403010043-1049357 No repository found containing: osgi.bundle,com.android.ide.eclipse.adt.package,22.6.0.v201403010043-1049357 No repository found containing: osgi.bundle,com.android.ide.eclipse.base,22.6.0.v201403010043-1049357 No repository found containing: osgi.bundle,com.android.ide.eclipse.ddms,22.6.0.v201403010043-1049357 No repository found containing: osgi.bundle,com.android.ide.eclipse.gldebugger,22.6.0.v201403010043-1049357 No repository found containing: osgi.bundle,com.android.ide.eclipse.hierarchyviewer,22.6.0.v201403010043-1049357 No repository found containing: osgi.bundle,com.android.ide.eclipse.ndk,22.6.0.v201403010043-1049357 No repository found containing: osgi.bundle,com.android.ide.eclipse.traceview,22.6.0.v201403010043-1049357 No repository found containing: osgi.bundle,overlay.com.android.ide.eclipse.adt.overlay,22.6.0.v201403010043-1049357 No repository found containing: org.eclipse.update.feature,com.android.ide.eclipse.adt,22.6.0.v201403010043-1049357 No repository found containing: org.eclipse.update.feature,com.android.ide.eclipse.ddms,22.6.0.v201403010043-1049357 No repository found containing: org.eclipse.update.feature,com.android.ide.eclipse.gldebugger,22.6.0.v201403010043-1049357 No repository found containing: org.eclipse.update.feature,com.android.ide.eclipse.hierarchyviewer,22.6.0.v201403010043-1049357 No repository found containing: org.eclipse.update.feature,com.android.ide.eclipse.ndk,22.6.0.v201403010043-1049357 No repository found containing: org.eclipse.update.feature,com.android.ide.eclipse.traceview,22.6.0.v201403010043-1049357 

Solutions Collecting From Web of "Android sdk требует инструментария разработчика Android версии 22.6.1 или выше"

Вчера я сообщил об этой ошибке . Решение заключается в использовании справки -> Установить новый вариант программного обеспечения с протоколом httpS: // (важно). Никаких специальных загрузок или переустановки не требуется, просто выберите правильный сайт обновления.

Выполните следующие шаги для обновления до 22.6.1.

  1. Загрузить архив ADT 22.6.1
  2. Откройте ADT, перейдите в Help -> установите новое программное обеспечение -> Добавить сайт -> Выберите архив и выберите ADT22.6.1.zip, загруженный на шаге 1.

  3. Нажмите OK, выберите инструмент разработчика и установите

  4. Перезапустить ADT

У меня была такая же проблема, когда проверка обновлений не нашла 22.6.1.

Я решил это, выбрав «Справка» -> «Установить новое программное обеспечение» и используя следующий сайт обновлений:

https://dl-ssl.google.com/android/eclipse/

Кроме того, вы можете скачать ZIP-версию сайта обновления 22.6.1 отсюда:

http://developer.android.com/sdk/installing/installing-adt.html

Вы можете перейти в Window-> Android SDK Manager и проверить, какая у вас версия. В моем случае это показывает, что у меня уже установлен инструментарий 22.6.1, но все равно получаю ошибку . Если у вас уже есть это или нет, вы можете сделать следующее, чтобы исправить.

  • Перейдите в Help-> Install New Software … В диалоговом окне, показанном ниже, нажмите кнопку «Добавить» в верхней правой части.
  • Вставьте « https://dl-ssl.google.com/android/eclipse/ » в «Местоположение». Вы можете назвать это чем угодно.
  • Нажмите «ОК» и следуйте по диалогу, нажав «Далее».
  • Если вам будет предложено рассказать, что у вас уже есть это, просто согласитесь, чтобы он обновлялся (или устанавливался, если он там не был).

Это должно решить проблему. Источник: http://codewriterstips.blogspot.nl