Для Android SDK требуется Android Developer Toolkit версии 22.0.0 или выше. Текущая версия – 21.1.0.v201302060044-569685.

Я обновил SDK до последней версии, то есть 22.0.0, из справки >> установите новое программное обеспечение, а затем я разместил URL-адрес « http://dl-ssl.google.com/android/eclipse/ », после чего я отметил «Инструменты разработчика» »И« Плагин NDK », затем он говорит« Не удается выполнить запрос ». Подробнее см. Журнал ошибок. «Android DDMS» будет проигнорирован, поскольку он уже установлен. «Android Traceview» будет проигнорирован, поскольку он уже установлен. «Средства разработки Android» будут проигнорированы, поскольку они уже установлены. «Android Hierarchy Viewer» будет проигнорирован, поскольку он уже установлен. «Tracer for OpenGL ES» будет проигнорирован, поскольку он уже установлен. «Android Native Development Tools» будет проигнорирован, поскольку он уже установлен.

Пожалуйста помоги! Кто угодно

Что сработало для меня, было следующее:

1- Перейдите в раздел Справка-> Установить новое программное обеспечение

2- Где говорится: «Работайте с» выберите «Сайт обновления Android Developer Tools – http://dl-ssl.google.com/android/eclipse/ »

3-После обновления выберите «Инструменты разработчика» и «Плагины NDK», убедитесь, что вы выбрали главную ветвь

4-Click next

5 – Следующее сообщение должно быть в деталях «ваш первоначальный запрос был изменен» «Android DDMS уже установлена, поэтому вместо этого будет выполнено обновление»,

6 Нажмите «Далее» и «Примите условия», и все готово.

На прошлой неделе у меня была такая же проблема, я все пробовал, но мне ничего не помогло.

Наконец, исправлено это только путем повторной загрузки пакета ADT целиком снова.

Попробуйте все до https : //dl-ssl.google.com/android/eclipse/, а не http

Я исправил это, выполнив следующее:

Справка -> Eclipse Marketplace -> Нажмите вкладку «Популярная» (или на вкладке «Установленные») -> Найдите «Средства разработки Android для Eclipse» -> нажмите кнопку «Обновить».

Если вы обновите sdk, а затем получите эту ошибку «Для Android SDK требуется Android Developer Toolkit версии 22.0.0 или выше. Текущая версия – 21.1.0.v201302060044-569685. Пожалуйста, обновите ADT до последней версии».

То вы можете сделать то, что делают JFDionne ….

Справка -> Eclipse Marketplace -> Нажмите вкладку «Популярная» (или на вкладке «Установленные») -> Найдите «Средства разработки Android для Eclipse» -> нажмите кнопку «Обновить».

Моя проблема также исправлена, делая выше шаги …..

Для меня функция автоматического обновления из eclipse не работала. Поэтому я вручную загрузил eclipse adt с сайта Android . Извлечен zip и использовал его как новый локальный сайт для плагинов. Он устанавливает и перезапускает затмение, и проблема исчезла.

Решила эту проблему в Ubuntu 12:04 LTS запустила Eclipse как root.

Sudo eclipse

Вы снова можете скачать с https://developer.android.com/sdk/index.html, и все будет в порядке.