Intereting Posts
Андроидный фрагмент onRestoreInstanceState Навигационный ящик выделяет выбранный элемент не работает Android RecyclerView с GridLayoutManager делает диапазон элементов несколькими рядами Объединить несколько приложений в одном приложении Зачем использовать аргумент, когда вы можете выполнять одну и ту же задачу с помощью статических переменных? Уведомления о двойном gcm Как создается действие Android (используя отражение)? «Пространство имен не связано» в проверке Android Lint XmlPullParserException Бинарная строка XML-файла # 17 тег <vector> требует viewportWidth> 0 Сохранение состояния в сложных виджетах вида Android OpenCV getPerspectiveTransform и warpPerspective Студия Android: эмулятор работает, но не отображается в Run App «выберите запущенное устройство» Как включить и использовать ZXing Library в Android с eclipse? Не удалось конвертировать в формат Dalvik: невозможно выполнить dex: Java heap space Как ссылаться на файл в необработанной папке на Android

Android: rebuild теперь требует уровня соответствия компилятора 5.0 или 6.0. Вместо этого найдено «1.7». Зачем удалять @Override?

Возможный дубликат:
Для Android требуется уровень соответствия компилятора 5.0 или 6.0. Вместо этого найдено «1.7». Используйте Android Tools> Fix Project Properties

После восстановления моего компьютера я получаю эту ошибку при импорте моих проектов.

Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix Project Properties. 

Я видел, как это было поднято на SO, и я могу исправить свои проекты, выполнив Fix Proj, а затем удалив все мои @OVerrides.

Этот вопрос, почему мне сейчас требуется удалить @Overrides? И это изменит мои проекты?

ура

Изменить, чтобы добавить информацию о прохождении.

Я импортирую проект, я получаю ошибку, показанную выше. Затем я сделаю « Android Tools > Fix Project Properties . Это теперь устанавливает Project> Properties Java Compile to Compiler Compliance Level 1.5

После этого я остаюсь с рядом ошибок в моих java-файлах. В этом конкретном проекте мои ошибки включены

 @Override public void run() {... 

Ошибка маркера слева от ошибки …

 Multiple markers at this line - The method run() of type new Runnable(){} must override a superclass method - implements java.lang.Runnable.run 

Ошибка наведения в eclipse предполагает, что я удаляю @Override, чтобы исправить эту проблему, и если я удалю @Override, она устранит проблему, и мой проект теперь компилируется и запускается. Это неверно?

Ps Я только что написал все это, изменил уровень соответствия Java на 1.6 и все ошибки переопределения исчезли! Может ли кто-нибудь объяснить (и я полностью понимаю, что это может быть совершенно без темы), почему?

Solutions Collecting From Web of "Android: rebuild теперь требует уровня соответствия компилятора 5.0 или 6.0. Вместо этого найдено «1.7». Зачем удалять @Override?"

Не удаляйте нотацию @overide.

Вы должны установить совместимость проекта с Java 5.0 или Java 6.0.

Для этого два варианта:

1) щелкните правой кнопкой мыши по вашему проекту и выберите "Android Tools -> Fix Project Properties" (если это не работает, попробуйте второй вариант)

2) щелкните правой кнопкой мыши на вашем проекте и выберите "Properties -> Java Compiler" , установите флажок «Включить специальные настройки проекта» и выберите «1.5» или «1.6 » в поле «Параметры соответствия компилятора» .

Обратитесь к этой ССЫЛКЕ для справки

ПЕРВОЕ ОБНОВЛЕНИЕ ВСЕГО ….

Теперь щелкните правой кнопкой мыши на вашем проекте и выберите «Инструменты Android», затем «Добавить библиотеку поддержки», он обновит, затем попробует материал, который я скопировал сверху ….

1) щелкните правой кнопкой мыши по вашему проекту и выберите «Инструменты Android -> Исправить свойства проекта» (если это не работает, попробуйте второй вариант)

2) щелкните правой кнопкой мыши на вашем проекте и выберите «Свойства -> Компилятор Java», установите флажок «Включить специальные настройки проекта» и выберите «1.5» или «1.6» в поле «Параметры соответствия компилятора».

Большое спасибо Агарвалу Шанкару за начало …