Android: java.io.IOException: неправильная версия хранилища ключей

Эта ошибка возникает, когда я пытаюсь войти в мое приложение с более низкой версией Android. Все телефоны / эмуляторы, у которых есть Android 4.3 и выше, могут входить в систему без ошибок, если в качестве телефонов и планшетов с версией 4.1.1 приведена ошибка ниже. Мы считаем, что это из-за более низкой версии Android и ищет решение.

java.io.IOException: Wrong Version of key store at com.android.org.bouncycastle.jce.provider.JDKKeyStore.engineLoad(JDKKeyStore.java:812) at java.security.KeyStore.load(KeyStore.java:589) 

В настоящее время я пытался снизить мою версию ботинка-замка до 146, как в этой ссылке

Ошибка неправильной версии хранилища ключей. Как создать сертификат = 1 кейстор?

Я застрял в этой проблеме уже целый день, поэтому любая помощь будет очень признательна.

С Уважением,

Райан

Solutions Collecting From Web of "Android: java.io.IOException: неправильная версия хранилища ключей"