Intereting Posts
Не удается создать проект с помощью Travis-CI и Android Является ли Zeroconf API доступным для Android? Студия Android не распознает запущенный эмулятор Коснитесь прокрутки на панели «Просмотр флипперов» в Android? Панель инструментов Android + ActionBarDrawerToggle не меняется на стрелку Кнопка закрытия кнопки закрытия даже при использовании FragmentTransaction.addToBackStack () Просмотр подкачки Виджет панели поиска не запускает поисковую активность Android Studio, как упаковать один AAR из нескольких проектов библиотеки? Текст «Незарегистрированный Android-приложение» отображается в диалоговом окне разрешения информации профиля пользователя Android – Как печатать с устройства Android? Android & OOP – глобальные переменные против унаследованных геттеров во фрагментах Мне нужны предложения по отправке push-уведомлений API Google Play Музыки для Android Центр Горизонтальная последняя строка с использованием диапазона Recycler GridLayoutManager

Утилита Android-установки «installDebug» перестала работать после обновления

Задача installDevDebug перестала работать после обновления плагина gradle с 2.1.3 до 2.3.3

./gradlew installDevDebug ... Unable to install /Users/user/Android/MyApp/app/build/outputs/apk/App-1.34.0-dev- debug-unaligned.apk com.android.ddmlib.InstallException: Failed to install all at com.android.ddmlib.SplitApkInstaller.install(SplitApkInstaller.java:96) at com.android.ddmlib.Device.installPackages(Device.java:904) at com.android.builder.testing.ConnectedDevice.installPackages(ConnectedDevice.java:136) at com.android.build.gradle.internal.tasks.InstallVariantTask.install(InstallVariantTask.java:134) at org.gradle.internal.reflect.JavaMethod.invoke(JavaMethod.java:73) 

build.gradle

 ... buildscript { ext.gradle_plugin_version = '2.3.3' } android { compileSdkVersion 25 buildToolsVersion "25.0.3" ... productFlavors { prod { } dev { minSdkVersion 21 multiDexEnabled true } } } 

Может ли кто-нибудь объяснить, что изменилось в плагине градиента, и как исправить эту проблему? Может быть, проблема связана со сборкой? Спасибо.

Я обнаружил, что мне нужно было указать этот репозиторий maven, в то же время я обновил свой Intellij до 2017.2 (что и заставило меня модернизировать плагин плагина).

 allprojects { repositories { jcenter() maven { url "https://maven.google.com" } } }