Intereting Posts
Динамическая установка представлений с параметром LayoutParams.addRule на последнюю позицию представления Не удается использовать вкладки с Шерлоком Почему openFileChooser в WebChromeClient скрыт от документов? Безопасно ли использовать этот метод? Изменить положение текста с плавающей меткой TextInputLayout Запрос и разрешение WRITE_EXTERNAL_STORAGE во время выполнения не влияет на текущий сеанс Номер телефона не отображается на CallStateChanged Android Неверный размер экрана заставки Java.lang.RuntimeException: Parcelable столкнулся с IOException, записывающим сериализуемый объект (name = com.jaapp.treeview.InMemoryTreeStateManager) Доступны ли отметки для навигации по просмотру плагинов для использования в Android? Activity.showDialog, когда активность не может быть на переднем плане Итерация через JSONObject Невозможно включить в android.app.Fragment Ошибка Xamarin.IOS. Невозможно разрешить ссылку: C: / Program Files (x86) /../ Xamarin.iOS / v1.0 / Фасады / System.Private.CoreLib.InteropServices.dll DrawableLeft получает совпадение с подсказкой с помощью TextInputLayout android Слушайте и отвечайте ANR?

Android-Gradle: возникла проблема настройки root-проекта

Я перешел из eclipse в андроид-студию. Я создаю новый проект, и я хочу запустить его в режиме genymotion. Когда я нажимаю значок запуска, он начинает компилироваться и давать мне эту ошибку:

Error:Gradle: A problem occurred configuring root project 'Khabar'. > Could not resolve all dependencies for configuration ':classpath'. > Could not resolve com.android.tools.build:gradle:1.1.0. Required by: :Khabardar:unspecified > Could not GET 'https://jcenter.bintray.com/com/android/tools/build/gradle/1.1.0/gradle-1.1.0.pom'. > d29vzk4ow07wi7.cloudfront.net 

Это некоторые части моего build.gradle:

  apply plugin: 'com.android.application' android { compileSdkVersion 20 buildToolsVersion "20.0.0" defaultConfig { applicationId "example.ir.khabar" minSdkVersion 8 targetSdkVersion 20 versionCode 1 versionName "1.0" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } 

Build.gradle в корне:

  apply plugin: 'com.android.application' android { compileSdkVersion 20 buildToolsVersion "20.0.0" defaultConfig { applicationId "example.ir.khabar" minSdkVersion 8 targetSdkVersion 20 versionCode 1 versionName "1.0" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) compile 'com.android.support:appcompat-v7:20.0.0' compile files('libs/universal-image-loader-1.8.4-with-sources.jar') } 

Не могли бы вы помочь мне? Моя версия градиента – град-2.2.1 – все

Для меня решение заключалось в том, чтобы добавить http-url для jcenter вместо https:

 buildscript { repositories { jcenter { url "http://jcenter.bintray.com/" } } dependencies { classpath 'com.android.tools.build:gradle:1.1.0' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } }