Intereting Posts
Как создать пользовательский счетчик, как рамка вокруг спиннера с треугольником вниз с правой стороны? OnClickListener на вкладках не работает Proguard с Android и клиентом API Google «Нет, отсутствует функция: WATCH», когда я пытаюсь запустить приложение для смартфонов с помощью приложения для ношения? OnTouch дает странные сенсорные точки Android Использование параллельного использования Android Десятичная запятая или десятичная запятая в Android Использование акселерометра в манифесте Опрос против Push – любые причины, чтобы избежать Push-уведомлений? Масштабирование проблемы на Android – почему картина такая неуклюжая? Создание серийного номера, специфичного для устройства Как включить Jack (набор компиляторов Java для Android) в студии Android Galaxy Nexus медленный с анимацией Имитация низкой батареи и низкой памяти в Android Как преобразовать существующее веб-приложение Angular1 в приложение Cordova?

Android Gradle Как создать для Android API Google 4.2.2 не для Android 4.2.2

Можно ли создать для Android Google API SDK вместо обычного Android SDK с градиентом?

Мне нужны API Карт Google в моем проекте, поэтому мне нужно изменить цель сборки. Я могу найти только образцы с версией сборки «17» compileSdkVersion 17 buildToolsVersion '17 .0.0 '

Есть идеи, как это сделать?

Solutions Collecting From Web of "Android Gradle Как создать для Android API Google 4.2.2 не для Android 4.2.2"

я понял:

1) используйте Android SDK Manager и получите API Google для нужных вам версий Android (запустите его из Android Studio, он отделен от вашего старого менеджера sdk, если вы раньше использовали eclipse)

2)

  • Перейдите в раздел «Файл> Структура проекта> SDK»
  • Щелкните знак плюса и выберите «Android SDK»,
  • Появится всплывающее окно, перейдите в папку установки Android Studio и выберите подпапку «sdk»
  • Появится другое всплывающее окно: выберите «API Google (#. #. #)»,

3) В том же окне «Структура проекта»: выберите «Android #. #. # API Google» в SDK проекта нажмите «Применить / ОК».

4) Теперь в ваших файлах build.gradle замените

android { ... compileSdkVersion 17 ... } 

с

 android { ... compileSdkVersion "Google Inc.:Google APIs:17" ... } 

6) перезапустить Android Studio

Это сделало это для меня для google apis 16. Если у вас все еще возникают проблемы:

  • Перейдите в раздел «Файл> Структура проекта> SDK»
  • Выберите API-интерфейс Google API> classpath
  • Убедитесь, что в jar-файлах API Google (например, Android Studio / sdk / add-ons / addon-google_apis-google-16 / libs / maps.jar)
  • Если не добавить их вручную (это нужно сделать для apis 17)
  • Перезапустить Android Studio