Intereting Posts
Вернитесь к первому / основному виду деятельности без его перезагрузки Android – WebView не воспроизводит видео на YouTube Доступ к представлениям другого элемента ListView из некоторого элемента Передача данных между внешним профилем приложения и внутренним профилем в Android Lollipop Как обновить Android Studio автоматически? SQLite сортирует специальные символы в алфавитном порядке Как набить вид из XML в Android? Когда метод getItemCount и getItemViewType вызывается в адаптере Recycler Подключение к интернету приостановлено после блокировки телефона Android Android gradle build с библиотекой, не может найти символ Android – Фрагмент экрана вращается Как сгенерировать несколько apk (используя gradle, libGDX) Как я могу предотвратить закрытие приложения Phonegap при возникновении ошибки? Значок подсчета уведомлений панели действий (значок), например, Google Android: BitmapDrawable.Draw (Canvas) Кажется не работает

Android Exclamatory red mark

Я очень новичок в Android. Всякий раз, когда я создаю новый проект, используя новое рабочее пространство, я получаю восклицательный знак красного цвета в Eclipse в моем проекте и ошибку в Appcompat . Я искал здесь ответ, но ответа не было, что я искал, поэтому я просто спросил об этом. Когда я создаю рабочее пространство в DDMS, он отображает это:

 Sending Tracking request failed! 

На Android после создания нового проекта

 WARNING: unable to write jarlist cache file here, src file, layout file not available. 

Я много искал и не нашел решения.

Хорошо, сначала первое. Google Eclipse больше не поддерживается. Единственной официальной IDE для Android Development является Android Studio Download .

Вот объявление о завершении поддержки Eclipse

За последние несколько лет наша команда сосредоточилась на улучшении опыта разработки приложений Android с Android Studio. С момента запуска Android Studio мы были впечатлены волнением и положительной обратной связью. Как официальная Android IDE, Android Studio дает вам доступ к мощному и всеобъемлющему набору инструментов для разработки вашего приложения на платформах Android, будь то на телефоне, запястье, автомобиле или телевизоре.

С этой целью и сосредоточить все наши усилия на создании Android Studio все лучше и быстрее, мы заканчиваем разработку и официальную поддержку Android Developer Tools (ADT) в Eclipse в конце года. Это включает в себя плагин Eclipse ADT и систему Android Ant.

Обратите внимание, что число пользователей, использующих Eclipse для разработки приложений для Android, снижается. Вы будете получать меньше и меньше поддержки даже на Stackoverflow с течением времени. В целом, лучше просто сделать переключатель, пока вы только начинаете.

Проверьте первую ссылку, вы увидите замечательную документацию в Android Studio IDE


Если вам нужно 100% использовать Eclipse …

ОК, поэтому у вас есть задание, требующее Eclipse, или есть другая причина, а затем проверьте эту документацию Eclipse .

Кроме того, здесь представлен список всех различных значков, которые могут отображаться Eclipse ( кредит для списка значков ).

Проблемы с созданием пути иногда легко пропустить среди других проблем в проекте. В представлении «Проводник пакетов» и «Проводник проекта» теперь отображается новый декоратор проектов Java и рабочих наборов, содержащих ошибки пути построения:

Введите описание изображения здесь

Конкретные ошибки можно увидеть в представлении «Проблемы», и если вы откроете меню просмотра и выберите «Группа»> «Тип проблемы Java», все они отображаются в категории «Путь сборки»:

Введите описание изображения здесь

См. Также эту ссылку.

Если вы перейдете в папку appcompat_v7 / bin, вы увидите, что файл «jarlist.cache» не отображается или не синхронизирован. Вам нужно обновить папку appcompat_v7, только нажмите F5 над этой папкой.

Папка appcompat_v7 добавляется, потому что вы используете компонент панели действий.

Ааа. Чтобы избежать создания новой папки appcompat_v7_XX при создании нового проекта, выберите API уровня LEVEL 14 в качестве SDK Minimun. После того, как вы должны модифицировать AndroidManifest.xml и поместите необходимый вам уровень.

Изменить его android: targetSdkVersion = "19" />

Удалите все appcompat_v7_XX. Это ошибка.

С помощью appcompat_v7 вы увидите, что Eclipse создает два XML-файла: Activity_main.xml и fragment_main.xml. Если вы хотите иметь возможность создавать проект по-старому только с помощью Activity_main.xml, выполните следующие действия:

Сделайте копию папки «BlanckActivity», расположенной по этому пути: \ sdk \ tools \ templates \ действия предыдущей версии ADT.

Переименуйте папку как «BlankActivityNoFragment», затем отредактируйте имя поля файла «template.xml» с помощью блокнота как name = «BlankActivityNoFragment»,

Скопируйте новую папку в тот же путь к новой Eclipse IDE: sdk / tools / templates / activities

Теперь вы увидите новый шаблон, когда идете создать новый проект. Не забудьте выбрать минимально необходимый SDK API 14

Если вам не нужна поддержка библиотеки appcompat, просто удалите ее из своего проекта, выполнив следующие шаги:

  1. Щелкните правой кнопкой мыши по проекту
  2. Выберите свойства
  3. В диалоговом окне выберите android с левой стороны
  4. В разделе диалогового окна проверки
  5. Удалите библиотеку appcompat, выбрав ее и нажмите remove
  6. Расширяет ваш MainActivity.java с активностью

Вы можете успешно запустить проект.

Если вам нужна поддержка appcompat, выполните следующие действия:

  1. Загрузите последнюю версию appcompat с помощью Sdk Manager
  2. Импортировать проект appcompat в своем затмении
  3. Добавить его в качестве проекта библиотеки
  4. Расширьте свою MainActivity с помощью AppCompatActivity.

Если у вас возникла проблема с библиотекой app_compact … Это решение

Надеюсь, это сработает ….

Согласно документации

Оформляет проекты Java и рабочие наборы, содержащие ошибки пути сборки

Могут быть несколько причин. В большинстве случаев это могут быть некоторые из нижеприведенных причин,

  1. Вы удалили некоторые .jar-файлы из папки / lib
  2. Вы добавили новые файлы .jar
  3. Вы добавили новые файлы .jar, которые могут конфликтовать с другими

Итак, что делать, мы должны разрешить эти отсутствующие / обновленные / new_added файлы jar.

  • Щелкните правой кнопкой мыши по проекту и перейдите к свойствам
  • Выберите путь сборки Java
  • Перейдите на вкладку «Библиотеки»
  • Удалите ссылки на файлы jar, которые вы уже удалили. Рядом с ними будет красный знак, чтобы вы могли легко идентифицировать их.
  • Добавьте ссылки на недавно добавленные файлы .jar, используя Добавить JARs Обновить проект

Это решит проблему, если это связано с одной из вышеуказанных причин.

Все еще сталкивается с проблемой? Попробуйте следующее:

Перейти к Windows -> Настройки -> Android -> Сборка и снятие флажка «Пропустить упаковку и удаление до экспорта или запуска», а затем перезапустить Eclipse.