Библиотека поддержки Android Eclipse: обязательная версия пуста

Я только что загрузил и установил последний пакет ADT для Windows, доступный с веб-сайта разработчика Android. После этого я установил все пакеты в диспетчере SDK, в том числе «Библиотека поддержки Android Rev. 18». Наконец, я установил последний ADT через меню «Справка> Установить новое программное обеспечение …» в Eclipse.

Я строго следовал следующему руководству, чтобы создать свой первый проект:

http://developer.android.com/training/basics/firstapp/creating-project.html

Но на последнем шаге я прихожу к ошибке, показывая обновленную версию библиотеки поддержки, которую я установил, и требуемую версию -blank-:

Http://i.stack.imgur.com/CScNj.png (извините, я не могу опубликовать изображения)

Я проверил «Window> Preference», что Eclipse указывает на правый каталог SDK. Mine содержит каталоги: надстройки, инструменты для сборки, документы, дополнительные функции, платформы, инструменты платформы, образцы, источники, системные изображения, временные параметры, инструменты. Я предполагаю, что это правильно.

Я читал в другом месте о перемещении файлов из \ extras \ android \ совместимость в \ extras \ android \ support, однако у меня нет каталога совместимости. Кроме того, моя папка поддержки содержит папки: samples, v4, v7, v13 – если это что-то значит (я предполагаю, что проблема здесь где-то здесь). Я установил пакеты в Android SDK Manager с правами администратора и попытался создать проект Android в Eclipse с правами администратора.

Не уверен, куда идти отсюда. Кто-нибудь еще испытал эту ошибку и может указать мне в правильном направлении?

Вы можете временно отказаться от предыдущей версии: просто загрузите http://dl-ssl.google.com/android/repository/tools_r22-windows.zip и извлеките его в папку «..Android \ android-sdk \ tools». Он решил проблему в моем случае.

UPDATE: Как предложил @DogGuts, лучший способ – скачать правильные шаблоны здесь и заменить файлы в «\ Android \ android-sdk \ tools \ templates \ activities"

И лучшим решением является обновление SDK до версии 22.2.1 🙂

Фактически это, по-видимому, является фактической ошибкой в ​​инструментах SDK: https://code.google.com/p/android/issues/detail?id=60149 см. № 55 для обходного пути без необходимости переопределять инструменты SDK.