Intereting Posts

Android – API фрагментов для уровня API <11

Я столкнулся с проблемой для динамических форм в своем приложении, которая подходит для Android 2.1 и выше. Я знаю, что есть новый API-интерфейс Fragment с уровня API 11 (Android 3.0 Honeycomb), но также я прочитал статью – http://android-developers.blogspot.com/2011/03/fragments-for-all.html, в которой говорится о фрагменте Api доступен также для уровня API ниже, чем 11, так называемого пакета Compatiblity. Я установил его через SDK, но я не могу использовать его в своем приложении, например, я не могу импортировать android.app.FragmentManager, приложение этого не знает.

Знаете ли вы, как его решить? Является ли API-интерфейс Fragment истинно доступным для более старых уровней API? Если да, то как это сделать? Или есть другое решение, такое как API фрагментов? Мне понадобится для динамических сгенерированных форм, если это возможно

благодаря

Hmyzak

Solutions Collecting From Web of "Android – API фрагментов для уровня API <11"

Вот хороший учебник о том, как реализовать Fragments на старых версиях Android, надеюсь, это поможет вам.

Android Studio:

Добавить зависимость для пакета совместимости поддержки v4:

 dependencies { ... compile 'com.android.support:support-v4:21.0.+' ... } 

А затем используйте import android.support.v4.app.Fragment; Вместо import android.app.Fragment; В импорте.

Вам нужно добавить пакет в путь сборки.

Используйте ActionBarSherlock . Он поставляется с большим количеством рабочих примеров.