Intereting Posts
Карты Google v2 При использовании фрагментов при двойном щелчке Выпадающее меню или просмотр на слайде Как получить данные из нескольких таблиц / классов Parse.com Как повторно запустить неудачный тест в Espresso? – мозговой штурм Как поместить кнопку между двумя макетами Com.android.volly.AuthFailureError при выполнении основного запроса POST на сервер django Как я могу использовать эффекты перехода Android в веб-представление? ImageButton не выделяет клик с помощью Прозрачного фона Android AndEngine: правильная обработка обнаружения коллизий Android N – приложение не поддерживает многооконный Android OnClickListener не работает в GridView (только для версии 2.2) Android: макет по умолчанию для списка с заголовком и субтитрами Android java.lang.IllegalMonitorStateException: объект не заблокирован потоком перед ожиданием () Android BLE: onCharacteristicRead (), по-видимому, заблокирован потоком Загрузите приложение Android с другим кодом версии, но с той же версией

Android-версия Неподдерживаемая версия плагина Gradle

Подобно заданному здесь вопросу: Android-версия не поддерживаемой версии gradle, но я использую совместимую версию , но ответ там не устраняет проблему для меня.

Я использую Android Studio Beta 0.8.1 под Ubuntu 14.04 LTS. Я пытаюсь импортировать проект, который делится с моей командой, но когда я клонирую проект и пытаюсь его построить, я получаю эту ошибку:

Error:The project is using an unsupported version of the Android Gradle plug-in (0.11.2) <a href="fixGradleElements">Fix plug-in version and re-import project</a> 

Когда я нажимаю ссылку, я получаю эту ошибку:

 12:21:30 PM Quick Fix Failed Unable to find any references to the Android Gradle plug-in in build.gradle files. Please click the link to perform a textual search and then update the build files manually. 

Вот соответствующий раздел моего файла build.gradle:

 buildscript { ... dependencies { classpath 'com.android.tools.build:gradle:0.11.+' } } 

Я вручную установил последнюю версию Gradle в попытке исправить эту проблему (Ubuntu действительно хочет, чтобы у меня была версия 1.4, но наш проект настроен для Gradle 1.11+. Вот результат «gradle -v»:

 ------------------------------------------------------------ Gradle 1.11 ------------------------------------------------------------ Build time: 2014-02-11 11:34:39 UTC Build number: none Revision: a831fa866d46cbee94e61a09af15f9dd95987421 Groovy: 1.8.6 Ant: Apache Ant(TM) version 1.9.2 compiled on July 8 2013 Ivy: 2.2.0 JVM: 1.8.0_05 (Oracle Corporation 25.5-b02) OS: Linux 3.13.0-30-generic amd64 

Я попытался настроить Android Studio на использование локальной установки Gradle (Файл> Настройки> Грейдл> Использовать локальное распределение градиентов), но это только приводит к ошибке, что данная задача не может быть найдена в корневом проекте. (?)

Когда я строю проект из командной строки с помощью команды «./gradlew clean assembleDebug», он отлично строится, и я могу установить и запустить APK.

Я не понимаю, что я делаю неправильно, или как это исправить. Любые подсказки были бы глубоко оценены!

Для Android Studio 0.8.1 требуется градиент-плагин 0.12.

 buildscript { ... dependencies { classpath 'com.android.tools.build:gradle:0.12.+' } } 

Проверьте этот ответ на совместимость:

Обновление Android Studio Gradle до версии 0.5.0 – Gradle Migrating От 0,8 до 0,9 – Также обновление для Android Studio до 0.8.1

Теперь я понимаю, что я делаю неправильно. Более новая версия Andoid Studio, которую я установил, не поддерживает плагин gradle 0.11. *. Исправление состоит в том, чтобы обновить все мои файлы build.gradle, таким образом:

 buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.12.+' } } 

Поэтому я изменил «gradle: 0.11. +» На «gradle: 0.12. +».

Открыв файл build.gradle и просмотрев сообщения об ошибках, которые были отображены в соответствующих строках, я увидел, что они гораздо полезнее сообщений об ошибках, с которыми я столкнулся. Я искал способ обновить мою установку gradle или мой плагин gradle в Android Studio. Для Android Studio я хотел обновить файл сборки, чтобы указать другую версию плагина gradle. Я не понимаю, почему это было действительно необходимо – я ничего не изменил в исходном коде! – но Android Studio теперь с радостью построит и запустит мой проект.

Спасибо Габриэле Мариотти за разъяснения.

Я также получил эту ошибку в Linux Mint 17.

Я установил град из репозиториев Ubuntu, но это была версия 1.4. Поэтому я скачал 1.10, используя ppa:

 sudo add-apt-repository ppa:cwchien/gradle sudo apt-get update sudo apt-get install gradle-1.10 

Примечание. Не делайте sudo apt-get install gradle , так как новая версия (2.x в это время) также отклоняется Android Studio