Intereting Posts
Утечка памяти MediaControllerCompat Android getIntent () возвращает первое намерение Set android: текст из strings.xml Изображение android в списке, которое думает «за пределами» окна Плагин Android Emulator Jenkins не работает Как запретить обезьяне открывать строку состояния? Android-фрагменты: нужен ли пустой конструктор? Android с использованием макетов в качестве шаблона для создания нескольких экземпляров макета Организация файлов кода / файлов XML для Android SDK Gmail подписывается на интеграцию в приложение для Android, profilePhoto всегда null? Эмулятор Genymotion не запускается. Остается навсегда на черном экране "android" Горизонтальный салфетка не обнаружена в родительском элементе ScrollView Видео DRM WideVine, не воспроизводимое с помощью приложения-отправителя андроида Как отобразить мое местоположение на Google Maps для Android API v2 Как оставаться подключенным к службе Android между несколькими действиями?

Версия для Android 2.0 2.0 с выпуском Renderscript

Я обновил Android Studio до версии 2.0 Preview 2, затем получил ошибку. Режим поддержки Renderscript в настоящее время не поддерживается с помощью renderscript target 21+

Я использую renderscriptTargetApi 23

Renderscript в настоящее время не поддерживается с помощью Target 21+, поэтому просто измените цель на API 20, и это должно решить проблему. Таким образом, параметры, связанные с renderscript в вашем разделе конфигурации по умолчанию вашего файла gradle, должны выглядеть так:

renderscriptTargetApi 20 renderscriptSupportModeEnabled true 

Ошибка, связанная с renderscriptTargetApi , была исправлена ​​в модуле gradle-plugin 2.1.0 и Build-Tools 23.0.3. Попробуйте:

 buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:2.1.0' } } android { compileSdkVersion 23 buildToolsVersion "23.0.3" ... } 

@atabouraya, Это ошибка в инструментах построения. Проверьте версию сборки и, если она ниже 23.0.3, обновите их. Подробнее здесь: http://developer.android.com/intl/es/tools/revisions/build-tools.html в Build Tools, версия 23.0.3 (март 2016 г.)

@atabouraya, Должны быть изменения в build.gradle вашего приложения

Как предложено на сайте разработчика Android.

 android { compileSdkVersion 23 buildToolsVersion "23.0.3" defaultConfig { minSdkVersion 8 targetSdkVersion 19 renderscriptTargetApi 18 renderscriptSupportModeEnabled true } } 

Просто измените renderscriptTargetApi 23 на renderscriptTargetApi 20 и убедитесь, что ваша minSdkVersion меньше 21 .