Ошибка при установке Android-приложения с помощью Spotify SDK,

Я пытаюсь следовать руководству по использованию Spotify Beta SDK и постоянно получать эту ошибку, когда пытаюсь установить приложение на эмулятор (Nexus 6). Это [INSTALL_FAILED_NO_MATCHING_ABIS]. Я использую тот же код, что и в учебнике, я нашел кое-что о компиляции для ARM против Intel, но не уверен, что это значит / как использовать эту информацию. Благодаря!

Spotify SDK включает встроенную библиотеку только для архитектуры ARM и архитектуры ARM.

Поскольку INSTALL_FAILED_NO_MATCHING_ABIS вызвано устройством, которое APK не поддерживается APK (т. Е. APK не содержит встроенную библиотеку для архитектуры процессора устройства), я предполагаю, что вы пытаетесь запустить его на эмуляторе x86, который Spotify SDK не поддерживает.

Попробуйте создать эмулятор ARM, и он должен работать.

Изменить: для создания конфигурации эмулятора для ARM выполните следующие действия:

  1. Нажмите «AVD Manager» -> «Создать виртуальное устройство»
  2. Выберите «Nexus 6» -> «Далее»
  3. Выберите один с помощью armeabi-v7a ABI, как показано ниже:

Введите описание изображения здесь