Ошибка проекта AIDE и Eclipse

Я создал проект Android в AIDE на моем Android-телефоне, работающем под управлением ICS, а затем для создания APK я скопировал папку проекта на свой компьютер, и когда я открыл ее в Eclipse, я получил следующую ошибку:

[2012-03-28 09:04:04 – ColorFinder] Невозможно разрешить целевую «андроид-10»

Мой AndroidManifext.xml выглядит следующим образом:

<?xml version="1.0" encoding="utf-8"?> <manifest xmlns:android="http://schemas.android.com/apk/res/android" package="com.sikni8.colorfinder" android:versionCode="1" android:versionName="1.0" > <uses-sdk android:minSdkVersion="8" android:targetSdkVersion="11" /> <application android:icon="@drawable/icon" android:label="@string/app_name" > <activity android:screenOrientation="portrait" android:configChanges="orientation|keyboardHidden" android:theme="@android:style/Theme.NoTitleBar" android:label="@string/app_name" android:name=".MainActivity" > <intent-filter > <action android:name="android.intent.action.MAIN" /> <category android:name="android.intent.category.LAUNCHER" /> </intent-filter> </activity> </application> </manifest> 

Как узнать, какова минимальная и максимальная цель, созданная AIDE? На моем ПК я установил только Android 4.0.3 (API 15). Может быть, это и есть причина? благодаря

EDIT: у меня есть несколько OnClickListener для кнопок, но во время компиляции все четыре дают мне следующую ошибку: «Тип OnClickListener неоднозначен» Пример:

  clearValButton.setOnClickListener(new OnClickListener() { //@Override public void onClick(View z) { hMain.setEnabled(true); rMain.setEnabled(true); gMain.setEnabled(true); bMain.setEnabled(true); findViewById(R.id.dummyFocus).setFocusableInTouchMode(true); findViewById(R.id.dummyFocus).requestFocus(); Toast.makeText(MainActivity.this, "All inputboxes are now Enabled.", Toast.LENGTH_SHORT).show(); }}); 

Вы почти ответили сами:

 Unable to resolve target 'android-10' 

а также

 In my PC i only installed Android 4.0.3 (API 15) 

Таким образом, для проекта требуется Android 10, но вы получили только 15. Итак, что помешает вам установить Android-уровень 10 (2.3.3) с помощью Android SDK Manager или изменить Build Target на 15?