Когда я загружаю ADT, почему я получаю сообщение об ошибке «Для Android SDK требуется Android Developer Toolkit версии XX.XX или выше?»

Я только что обновил свои Android SDK Tools до версии 21.1. К сожалению, это вызывает ошибку при загрузке Android Developer Toolkit:

Для Android SDK требуется Android Developer Toolkit версии 21.1.0 или выше.

Текущая версия – 21.0.1.2012-12-6-2-58.

Обновите ADT до последней версии.

Когда я обновил SDK, меня предупредили, что мне может понадобиться обновить ADT. Я попытался сделать это, выбрав «Справка»> «Проверить наличие обновлений». К сожалению, это возвращает сообщение о том, что «Обновления не найдены».

Если я что-то пропустил, вот скриншот моего Android SDK Manager:

Android SDK Manager

Мне не хватает пакета установки? Нужно ли мне обновлять ADT (Eclipse) другим способом? Должен ли я просто загрузить новую копию ADT?

Solutions Collecting From Web of "Когда я загружаю ADT, почему я получаю сообщение об ошибке «Для Android SDK требуется Android Developer Toolkit версии XX.XX или выше?»"

По какой-то причине ADT (Eclipse) не подберет тот факт, что он действительно нуждается в обновлении. Поскольку встроенные инструменты для обновления не сработают, вам придется обойти их. В меню «Справка» вместо выбора «Проверить обновления» выберите «Установить новое программное обеспечение» (так что «Справка»> «Установить новое программное обеспечение»).

На экране «Доступное программное обеспечение» в раскрывающемся меню «Работа с» укажите:
https://dl-ssl.google.com/android/eclipse/, если он еще не доступен. Вы должны увидеть список опций, включая инструменты разработчика. Проверьте все, что вы хотите обновить. В списке флажков снимите флажок «Свяжитесь со всеми сайтами обновлений во время установки, чтобы найти нужное программное обеспечение».

Установка нового программного обеспечения

Нажмите «Далее» и следуйте указаниям остальных экранных подсказок. Вы можете быть предупреждены, что вместо установки будет выполнено обновление. Это нормально. Как только операция будет завершена, вы больше не получите «Android SDK требует Android Developer Toolkit verxion 21.1.0 или выше» при загрузке ADT.