Не удалось получить версию adb … Нет такого файла или каталога

Я запускаю Eclipse 4.2.1 на ubuntu 12.10, и я занят установкой плагинов Android для Eclipse. Пока все прошло хорошо, я установил плагин ADT и все такое, но теперь я на том этапе, где (после перезапуска eclipse) я должен указать Eclipse в каталог, в котором я установил SDK для Android …

Здесь устанавливается sdk:

/ Опт / Android-SDK-линукс

Но появляется следующее сообщение об ошибке:

Введите описание изображения здесь

Любые идеи относительно того, почему это может случиться с кем угодно? Заранее спасибо!

Я нашел ответ, проблема в том, что я запускал 64-битную систему (должен был упомянуть об этом). Вы можете найти решение здесь: Android SDK на 64-битной Linux-машине

Вы смотрели в / opt / android-sdk-linux / platform-tools и подтвердили, что adb там? Если вы только что загрузили SDK, последние версии могут не поставляться со всеми инструментами, поэтому вам нужно запустить диспетчер SDK, чтобы загрузить нужные вам вещи. Из / opt / android-sdk-linux / tools вы можете выполнить «./android sdk», который запустит менеджер Android SDK, и вы сможете загрузить инструменты и инструменты платформы (это должен элемент в верхней части списка под инструментами папка)

Вы уже запустили android sdk и установили инструменты для платформы Android? Если да, я не знаю, что происходит. Если вы еще этого не сделали, то это ваша проблема. ( android sdk – менеджер Android SDK.)

Если у вас есть 64-битная машина, вы должны попробовать ответить @robbin chander:

В Linux вам нужно установить библиотеку IA32. Поскольку 64-разрядный пакет ADT для Linux поставляется с 32-разрядным adb в adt-bundle-linux / sdk / platform-tools / adb … Это также проблема в других дистрибутивах, например Fedora 17

И попробуйте следующее:

 sudo apt-get install libc6-i386 lib32stdc++6 lib32gcc1 lib32ncurses5