Невозможно использовать фрагменты с пакетом совместимости с Android

В «Фрагментах для всех» Ксавьер Дюкроэт, Android SDK Tech Lead, говорит, что Google выпускает пакет совместимости с Android от SDK Manager.

Я установил его, но как я могу его использовать сейчас?

Как я могу интегрировать пакет Android Compatibility Package в свой проект?

Если вы используете версию 12 или более поздней версии библиотеки поддержки Eclipse для Android, просто щелкните ее правой кнопкой мыши и выберите «Инструменты Android»> «Добавить библиотеку совместимости» …

Существует файл .jar под названием android-support-v4.jar в каталоге {yoursdkpath}/extras/android/compatibility/v4/ . Скопируйте это в свою папку libs в корень вашего проекта и добавьте файл в путь сборки в Eclipse.

Премьер,

Я последовал примеру Fragments в блоге разработчиков Android, чтобы создать «обратное» совместимое приложение с использованием фрагментов. В этой статье содержится краткое упоминание о основной деятельности, которая использует макет с фрагментами.

Код для этой деятельности не интересен; Он просто вызывает setContentView () с заданным макетом:

Здесь следует упомянуть, что эта деятельность должна происходить из класса FragmentActivity, а не класса Activity. Это отбросило меня на некоторое время.

Удачи

См. Раздел «Фрагмент пакета совместимости с Android» может помочь вам

Проверьте раздел «Шаг 2: Настройка пути сборки» здесь.

Это легко с новым загруженным Eclipse. Если у вас есть все пути для настройки SDK и т. Д., Щелкните правой кнопкой мыши Project -> Android tools-> и нажмите «Добавить библиотеку совместимости», он добавит JAR-файл