Не удалось разрешить все зависимости для конфигурации ': ParseStarterProject: classpath'

Я пошел в обновленную версию до последней Android-студии, и теперь, когда я иду на сборку, я получаю следующую ошибку. Я понятия не имею, что происходит, и не знаю, как сделать всю вещь – stacktrace, о которой говорит, если это мне вообще поможет. Любая помощь будет принята с благодарностью.

Executing tasks: [:ParseStarterProject:clean, :ParseStarterProject:generateDebugSources, :ParseStarterProject:prepareDebugUnitTestDependencies, :ParseStarterProject:mockableAndroidJar, :ParseStarterProject:generateDebugAndroidTestSources, :ParseStarterProject:assembleDebug] Configuration on demand is an incubating feature. FAILURE: Build failed with an exception. * What went wrong: A problem occurred configuring project ':ParseStarterProject'. > Could not resolve all dependencies for configuration ':ParseStarterProject:classpath'. > Could not resolve com.parse.tools:gradle:1.+. Required by: Archive 2 2:ParseStarterProject:unspecified > Could not resolve com.parse.tools:gradle:1.+. > Failed to list versions for com.parse.tools:gradle. > Unable to load Maven meta-data from https://maven.parse.com/repo/com/parse/tools/gradle/maven-metadata.xml. > Could not GET 'https://maven.parse.com/repo/com/parse/tools/gradle/maven-metadata.xml'. > peer not authenticated * Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. BUILD FAILED Total time: 2.256 secs 

Вот мои файлы градиентов

 apply plugin: 'com.android.application' apply plugin: 'com.parse' buildscript { repositories { mavenCentral() maven { url 'https://maven.parse.com/repo' } } dependencies { classpath 'com.parse.tools:gradle:1.+' } } dependencies { compile 'com.parse.bolts:bolts-android:1.2.0' compile fileTree(dir: 'libs', include: 'Parse-*.jar') compile fileTree(dir: 'libs', include: 'ParseCrashReporting-*.jar') } android { compileSdkVersion rootProject.ext.compileSdkVersion buildToolsVersion rootProject.ext.buildToolsVersion defaultConfig { minSdkVersion rootProject.ext.minSdkVersion targetSdkVersion rootProject.ext.targetSdkVersion } sourceSets { main { manifest.srcFile 'AndroidManifest.xml' java.srcDirs = ['src'] res.srcDirs = ['res'] } } } 

2.

 // Top-level build file where you can add configuration options common to all sub-projects/modules. buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:2.1.0' classpath 'com.jakewharton.sdkmanager:gradle-plugin:0.12.+' } } allprojects { repositories { mavenCentral() } } ext { compileSdkVersion = 22 buildToolsVersion = "22" minSdkVersion = 9 targetSdkVersion = 22 } 

О проблеме сообщалось здесь: https://github.com/ParsePlatform/Parse-SDK-Android/issues/463

Возможно, парсер остановил «размещение своего плагина Gradle». Поэтому удалите

 maven { url 'https://maven.parse.com/repo' } 

Из 'репозиториев' и

 classpath 'com.parse.tools:gradle:1.+' 

Из "зависимостей"

Удалить:

  1. Применить плагин: 'com.parse'

  2. Classpath 'com.parse.tools:gradle:1.+'

  3. Maven {url ' https://maven.parse.com/repo '}

И перестроить проект. Все должно работать нормально.