Не удалось создать проект андроида с использованием gradle

У меня возникла проблема с созданием простого андроидного проекта с использованием Gradle. Мой файл сборки находится ниже:

buildscript { repositories { mavenCentral() // To use a development snapshot version of the plugin, add the // Sonatype Snapshots repository. maven { url "https://oss.sonatype.org/content/repositories/snapshots" } } dependencies { classpath 'org.gradle.api.plugins:gradle-android-plugin:1.2.1' } } apply plugin: 'android' repositories { mavenCentral() } // Sets the package version version = "1.0.0" // Signing configuration, valid for all builds (1) androidSignAndAlign { keyStore = "path/to/my/keystore" keyAlias = "my-key-alias" keyStorePassword = "mystorepass" keyAliasPassword = "myaliaspass" } // Configure the filtering of resources with properties from the Gradle's project scope (2) processResources { expand (project.properties) } // Configure a dedicated debug build (3) task configureDebug << { jar.classifier = "debug" } // Configure a dedicated release build (4) task configureRelease << { proguard.enabled = true } 

Ошибка, которую я получаю, такова:

  11:08:24.812 [ERROR] [org.gradle.BuildExceptionReporter] FAILURE: Build failed with an exception. 11:08:24.822 [ERROR] [org.gradle.BuildExceptionReporter] 11:08:24.829 [ERROR] [org.gradle.BuildExceptionReporter] * Where: 11:08:24.834 [ERROR] [org.gradle.BuildExceptionReporter] Build file 'C:\Users\Work\AndroidProjects\RssUnified\build.gradle' line: 114 11:08:24.840 [ERROR] [org.gradle.BuildExceptionReporter] 11:08:24.845 [ERROR] [org.gradle.BuildExceptionReporter] * What went wrong: 11:08:24.850 [ERROR] [org.gradle.BuildExceptionReporter] A problem occurred evaluating root project 'RssUnified'. 11:08:24.855 [ERROR] [org.gradle.BuildExceptionReporter] > For input string: "21 rc11" 11:08:24.864 [ERROR] [org.gradle.BuildExceptionReporter] 11:08:24.870 [ERROR] [org.gradle.BuildExceptionReporter] * Exception is: 11:08:24.875 [ERROR] [org.gradle.BuildExceptionReporter] org.gradle.api.GradleScriptException: A problem occurred evaluating root project 'RssUnified'. 11:08:24.880 [ERROR] [org.gradle.BuildExceptionReporter] at org.gradle.groovy.scripts.internal.DefaultScriptRunnerFactory$ScriptRunnerImpl.run(DefaultScriptRunnerFac tory.java:54) 11:08:24.885 [ERROR] [org.gradle.BuildExceptionReporter] at org.gradle.configuration.DefaultScriptPluginFactory$ScriptPluginImpl.apply(DefaultScriptPluginFactory.jav a:127) 

С использованием gradle 1.2

Edit: вот мой макет xml-файла

 <?xml version="1.0" encoding="utf-8"?> <RelativeLayout xmlns:android="http://schemas.android.com/apk/res/android" android:layout_width="fill_parent" android:layout_height="fill_parent" > </RelativeLayout> 

И вот активность

 public class RssListActivity extends Activity { /* * (non-Javadoc) * @see android.app.Activity#onCreate(android.os.Bundle) */ @Override protected void onCreate(Bundle savedInstanceState) { // TODO Auto-generated method stub super.onCreate(savedInstanceState); setContentView(R.layout.list_activity_layout); } } 

Структура проекта ниже:

 ├───.gradle │ └───1.2 │ └───taskArtifacts ├───assets ├───bin │ ├───classes │ │ └───com │ │ ├───jr │ │ │ ├───screenLogic │ │ │ └───screens │ │ └───richy │ │ └───rssunified │ └───res ├───build │ └───gen │ └───com │ └───richy │ └───rssunified ├───gen │ └───com │ └───richy │ └───rssunified ├───res │ ├───drawable-hdpi │ ├───drawable-ldpi │ ├───drawable-mdpi │ ├───drawable-xhdpi │ ├───layout │ ├───values │ ├───values-v11 │ └───values-v14 └───src └───com └───jr ├───screenLogic └───screens 

Вот что находится в корневой папке проекта

 AndroidManifest.xml assets bin build build.gradle gen gradle.properties ic_launcher-web.png local.properties project.properties res src 

И наконец, манифест андроида:

 <?xml version="1.0" encoding="utf-8"?> <manifest xmlns:android="http://schemas.android.com/apk/res/android" package="com.richy.rssunified" android:versionCode="1" android:versionName="1.0"> <uses-sdk android:minSdkVersion="8" android:targetSdkVersion="15" /> <application android:label="@string/app_name" android:icon="@drawable/ic_launcher" android:theme="@style/AppTheme"> </application> </manifest> ? <?xml version="1.0" encoding="utf-8"?> <manifest xmlns:android="http://schemas.android.com/apk/res/android" package="com.richy.rssunified" android:versionCode="1" android:versionName="1.0"> <uses-sdk android:minSdkVersion="8" android:targetSdkVersion="15" /> <application android:label="@string/app_name" android:icon="@drawable/ic_launcher" android:theme="@style/AppTheme"> </application> </manifest> 

Local.properties

 sdk.dir = C:/Program Files (x86)/Android/android-sdk 

project.properties

 # This file is automatically generated by Android Tools. # Do not modify this file -- YOUR CHANGES WILL BE ERASED! # # This file must be checked in Version Control Systems. # # To customize properties used by the Ant build system edit # "ant.properties", and override values to adapt the script to your # project structure. # # To enable ProGuard to shrink and obfuscate your code, uncomment this (available properties: sdk.dir, user.home): #proguard.config=${sdk.dir}/tools/proguard/proguard-android.txt:proguard-project.txt # Project target. target=android-15 

редактировать:

Я вернулся к старой версии плагинов adt / sdk и смог исправить проблемы выше, но после этого я теперь получил вышеприведенную ошибку:

 15:24:24.558 [LIFECYCLE] [org.gradle.TaskExecutionLogger] :androidProcessResources FAILED 15:24:24.571 [ERROR] [org.gradle.BuildExceptionReporter] 15:24:24.575 [ERROR] [org.gradle.BuildExceptionReporter] FAILURE: Build failed with an exception. 15:24:24.582 [ERROR] [org.gradle.BuildExceptionReporter] 15:24:24.588 [ERROR] [org.gradle.BuildExceptionReporter] * What went wrong: 15:24:24.597 [ERROR] [org.gradle.BuildExceptionReporter] Execution failed for task ':androidProcessResources'. 15:24:24.602 [ERROR] [org.gradle.BuildExceptionReporter] > Unexpected internal error near index 1 15:24:24.607 [ERROR] [org.gradle.BuildExceptionReporter] \ 15:24:24.613 [ERROR] [org.gradle.BuildExceptionReporter] ^ 15:24:24.621 [ERROR] [org.gradle.BuildExceptionReporter] 15:24:24.626 [ERROR] [org.gradle.BuildExceptionReporter] * Exception is: 15:24:24.631 [ERROR] [org.gradle.BuildExceptionReporter] org.gradle.api.tasks.TaskExecutionException: Execution failed for task ':androidProcessResources'. 15:24:24.636 [ERROR] [org.gradle.BuildExceptionReporter] at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.executeActions(ExecuteActionsTaskExecu ter.java:68) 

Как описано в:
http://tools.android.com/tech-docs/new-build-system/using-the-new-build-system#TOC-Working-with-and-Customizing-SourceSets

Расположение источников по умолчанию находится в src/<sourceset>

Имя вашего sourceset является main поэтому местоположение src/main

Кроме того, описывается свойство manifest :

Манифест, тип AndroidSourceFile, местоположение по умолчанию src/<sourceset>/AndroidManifest.xml

Я предполагаю, что декларация манифеста:

  manifest { srcFile 'AndroidManifest.xml' } 

Такая же, как и по умолчанию, и заканчивается местоположением:

 src/main/AndroidManifest.xml 

Который указан в сообщении об исключении.

Я думаю, что так работает плагин android.
Поправьте меня, если я ошибаюсь, я не знаю Gradle.

РЕДАКТИРОВАТЬ

Хорошо, теперь я знаю, что случилось. Ваш скрипт сборки смешивает настройки с двумя разными плагинами.

Изменить:

 classpath 'com.android.tools.build:gradle:0.1' 

в

 classpath 'org.gradle.api.plugins:gradle-android-plugin:1.2.1' 

Удалите блок android , но держите тело.

Удалите блок sourceSets с телом.

Тогда он должен работать, я проверил его на этот раз.

EDIT 2

Это ошибка, связанная с Windows, исправленная 6 дней назад:

https://github.com/jvoegele/gradle-android-plugin/pull/89

Что вы можете сделать, это загрузить последнюю версию плагина

 git clone git://github.com/jvoegele/gradle-android-plugin.git 

И установите его в локальный репозиторий maven:

 gradle install 

Затем добавьте mavenLocal() в репозитории:

 repositories { mavenCentral() mavenLocal() } 

И измените версию плагина на снимок:

 dependencies { classpath 'org.gradle.api.plugins:gradle-android-plugin:1.2.2-SNAPSHOT' } 

Мне кажется, что вы пытаетесь неправильно избежать обратную косую черту в одном из ваших файлов ресурсов Android, как указано в задаче androidProcessResources . Пожалуйста, проверьте свои файлы ресурсов или разместите их здесь, чтобы мы могли посмотреть на них.