Intereting Posts
Обработка полного дискового хранилища в Android Android – Как программно отслеживать использование памяти любого запущенного приложения на устройстве? Как проигрывать потоковое аудио в фоновом режиме на Android? Заменить определенный цвет в растровом изображении прозрачностью Система частиц libGDX Как читать данные с помощью сканера штрих-кода Bluetooth Symbol CS3070 на Android-устройство Как настроить пользовательское хранилище ключей для отладки в eclipse для Android Передача курсора между процессами (Parcelable Cursor) Изменение данных адаптера ListView без уведомления ListView Съемка и геотаг Создание пробного приложения Android, срок действия которого истекает через определенный период времени Android: проблема со скрытой панелью заголовков Android adb (OSX Lion) не распознает Galaxy Nexus, Jelly Bean Где android.os.SystemProperties? Как ограничить отображение элементов списка в ListView на 10 и последующих 10 после нажатия следующей кнопки

Неизвестная ошибка: невозможно построить: файл dx.jar не был загружен из папки SDK

Когда я пытаюсь запустить проект Android в Eclipse ADT, я вижу это в консоли:

[2017-03-24 15:34:41 - Dex Loader] Failed to load C:\Users\jaimemontoya\android-sdks\build-tools\26.0.0-preview\lib\dx.jar 

[2017-03-24 15:34:41 – CouponClub] Неизвестная ошибка: Не удалось построить: файл dx.jar не был загружен из папки SDK!

Введите описание изображения здесь

Я использую Eclipse Neon.2 Release (4.6.2):

Введите описание изображения здесь

Это конфигурация пакета, которую я видел в Android SDK Manager:

Введите описание изображения здесь

Я понял из этой ошибки, что он не смог загрузить dx.jar, потому что он пытается загрузить его «из папки SDK». В сообщении даже используется восклицательный знак, чтобы сказать это! Какую папку SDK она имеет в виду? Я думал, что в этом случае «C: \ Users \ jaimemontoya \ android-sdks» будет считаться папкой SDK. Вы знаете, где он ожидает найти файл «dx.jar»?

Сегодня у меня была такая же ошибка, и мне удалось найти ваш пост. И после нескольких попыток, я обнаружил, что удаление 26 rc1 Build-tools может помочь решить проблему.

Однако у меня была такая же проблема, я решил удалить затмение, а затем удалить всю папку … вы можете сделать это, нажав «Справка» (в то время как на затмении) —> затем «about eclipse» —> Затем «подробности установки» и удалить, после удаления всей папки, я повторно загрузил eclipse и все SDK из диспетчера загрузки SDK. И он снова начал работать для меня. Надеюсь, это сработает.

Чтение принятого ответа в Got «неподдерживаемый файл класса версии 52.0» после включения модуля в проект дало мне подсказку, мне нужно было найти решение.

Я закончил с этой установкой Android SDK:

Введите описание изображения здесь

Затем я переключился с «jre1.8.0_121» на «jre7», а также изменил уровень соответствия компилятора с «1,8» до «1,7»:

Введите описание изображения здесь

Введите описание изображения здесь

Мое приложение окончательно скомпилировано.