Предупреждение об отказе от просмотра иерархии

Я использовал средство просмотра иерархии в прошлом для изучения пользовательского интерфейса приложения. При использовании инструмента сегодня я получаю это предупреждение

vihaan@trojan:~/Downloads/adt-bundle-linux-x86-20131030/sdk/tools$ ./hierarchyviewer The standalone version of hieararchyviewer is deprecated. Please use Android Device Monitor (tools/monitor) instead. 

У меня работает eclipse, и когда я пытался использовать монитор, я столкнулся с проблемой «отладчик не может подключиться к порту».

Каков правильный способ использования монитора из eclipse и обеспечивает ли он такую ​​же функциональность, как и просмотрщик иерархии?