Импортировать новый отказ модуля Android для модуля JellyRefreshLayout

Я импортирую JellyRefreshLayout как modul (для некоторых обновлений)

Проверьте эту ссылку: https://github.com/allan1st/JellyRefreshLayout

Но я всегда получаю эту ошибку построения градиента:

Информация: задачи Gradle [: app: generateDebugSources,

:app:mockableAndroidJar, :app:prepareDebugUnitTestDependencies, :app:generateDebugAndroidTestSources, :jellyrefresh:generateDebugSources, :jellyrefresh:mockableAndroidJar, :jellyrefresh:prepareDebugUnitTestDependencies, :jellyrefresh:generateDebugAndroidTestSources] extractDebugAnnotations is incompatible with java 8 sources and has been disabled. extractReleaseAnnotations is incompatible with java 8 sources and has been disabled. :jellyrefresh:incrementalReleaseJavaCompilationSafeguard UP-TO-DATE :jellyrefresh:compileReleaseJavaWithJavac UP-TO-DATE :jellyrefresh:compileRetrolambdaRelease FAILED Error:Execution failed for task ':jellyrefresh:compileRetrolambdaRelease'. > Could not resolve all dependencies for configuration ':jellyrefresh:retrolambdaConfig'. > Could not resolve net.orfjackal.retrolambda:retrolambda:2.0.3. Required by: JellyRefreshLayout-master:jellyrefresh:unspecified > No cached version of net.orfjackal.retrolambda:retrolambda:2.0.3 available for offline mode. > No cached version of net.orfjackal.retrolambda:retrolambda:2.0.3 available for offline mode. 

Проект:

 // Top-level build file where you can add configuration options common to all sub-projects/modules. buildscript { repositories { jcenter() mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:2.1.3' classpath 'me.tatarka:gradle-retrolambda:3.2.0' } } allprojects { repositories { jcenter() } } 

График приложения:

 apply plugin: 'com.android.application' android { compileSdkVersion 23 buildToolsVersion "23.0.2" defaultConfig { applicationId "uk.co.imallan.jellyrefreshlayout" minSdkVersion 19 targetSdkVersion 22 versionCode 1 versionName "1.0" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) compile 'com.android.support:appcompat-v7:23.3.0' compile project(":jellyrefresh") } 

Модель библиотеки:

 repositories { mavenCentral() } apply plugin: 'com.android.library' apply plugin: 'me.tatarka.retrolambda' android { compileSdkVersion 23 buildToolsVersion "23.0.2" defaultConfig { minSdkVersion 19 targetSdkVersion 22 versionCode 1 versionName "1.0" } compileOptions { sourceCompatibility JavaVersion.VERSION_1_8 targetCompatibility JavaVersion.VERSION_1_8 } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) compile 'com.android.support:appcompat-v7:23.3.0' } 

Примечание: мой выбор JDK проекта и JDK по умолчанию: /Library/Java/JavaVirtualMachines/jdk1.8.0_73.jdk/Contents/Home

Пожалуйста посоветуй ! Благодаря !

Solutions Collecting From Web of "Импортировать новый отказ модуля Android для модуля JellyRefreshLayout"

Он теперь решен.

Проблема заключалась в том, что inner_impl.jar иногда не относится к пути класса retrolambda. Потому что одно из следующего:

  • Потому что зависимости могут быть обновлены во втором исполнении.
  • Возможно, это ошибка в плагине Android Gradle.

Решение: я запускаю очистку градиента и сборку в командах от терминала градиента до синхронизации градиента:

./gradlew clean assembleDebug

От терминала Gradle.

Проверьте этот полезный разговор:

https://github.com/evant/gradle-retrolambda/issues/105