Intereting Posts
Является ли android.os.Build.SERIAL уникальным? Как получить идентификатор файла, чтобы я мог выполнить загрузку файла из Google Диска API на Android Tab + ViewPager не обновляет вместо этого показывает странное предупреждение ожидаемое состояние 3 найдено 2 Не удается открыть файл PDF во внешнем приложении. Как найти температуру города по долготе и широте в андроиде? Android: Как сделать флип-анимацию для андроидной активности, как будто iphone flip горизонтально слева направо? Полезно ли использовать весь макет WebView в собственном приложении для Android? Как сортировать / упорядочивать ключи объекта JSON в android? Разница между onClickListener и onItemClickListener Android usb requestWait not return JAVA-Android – подтверждение сертификата X509 на сертификат CA (сертификат эмитента) Преобразование целочисленного значения цвета в RGB Не найден ресурс, который соответствует указанному имени (в 'text' со значением '@ string / continue_label') Android make? Attr / selectableItemBackgroundBorderless go дальше? Повторение уведомлений на Android 4

Как установить последнюю версию плагина ADT для eclipse

Я заинтересован в android. Я использую Eclipse с подключаемым модулем ADT, и я загрузил проект с сайта github и попытаюсь это понять.

Но файл xml не открывает сообщение об ошибке:

«Эта версия библиотеки рендеринга более поздняя, ​​чем ваша версия плагина ADT. Обновите плагин ADT».

Кажется, что моя версия ADT устарела для этого недавнего проекта, хотя я установил v23.0.2.1.

Мне нужна помощь, чтобы добраться до последней версии для ADT или другого решения для моей проблемы.

благодаря

Solutions Collecting From Web of "Как установить последнюю версию плагина ADT для eclipse"

Вы используете Eclipse ADT Bundle , я имею в виду – до выхода Android Studio 1.0 был ADT Bundle – Eclipse с дополнительными инструментами Android.

Ну, я вижу, он по-прежнему доступен для загрузки: http://tools.android.com/recent/eclipseadtbundleupdated

Если вы используете его, удалите его и загрузите чистую Eclipse с этого сайта: https://eclipse.org/downloads/packages/release/Mars/1

Если вы планируете разрабатывать и на других языках, кроме Android, предлагающих Java, загрузите, например: Eclipse IDE for C/C++ Developers

Я использовал Eclipse for Eclipse Eclipse IDE для Eclipse Committers 4.5.1` и Eclipse IDE для разработчиков Java EE, поэтому я уверен, что они высоко совместимы с новым ADT-плагином.


После установки Eclipse вам необходимо загрузить и распаковать Stand-alone SDK Tools , где вы найдете [здесь] http://developer.android.com/sdk/index.html#Другое

Примечание . Уже последней версией Android SDK является android-sdk_r24.4.1 .

После загрузки и распаковки Eclipse и Android SDK прочтите эту документацию: http://developer.android.com/sdk/installing/installing-adt.html или просто выполните следующие действия:

Чтобы добавить плагин ADT в Eclipse:

  1. Запустите Eclipse , затем выберите « Help > Install New Software .
  2. Нажмите « Add в верхнем правом углу.
  3. В появившемся диалоговом окне « Add Repository » введите ADT Plugin для Name и следующий URL для Location : https://dl-ssl.google.com/android/eclipse/

Примечание. Для сайта обновления Android Developer Tools требуется безопасное соединение. Убедитесь, что URL-адрес сайта обновления начинается с HTTPS.

  1. Нажмите « OK .
  2. В диалоговом окне « Available Software » установите флажок « Developer Tools и нажмите « Next .
  3. В следующем окне вы увидите список инструментов для загрузки.
  4. Нажмите « Next .
  5. Прочтите и примите лицензионные соглашения, затем нажмите « Finish . Если вы получите предупреждение о безопасности, указывающее, что подлинность или действительность программного обеспечения не может быть установлена, нажмите « OK . По завершении установки перезапустите Eclipse.

Настройка плагина ADT

После перезапуска Eclipse вы должны указать местоположение своего Android SDK directory :

  1. В появившемся окне «Добро пожаловать в Android» выберите « Use existing SDKs .
  2. Просмотрите и выберите местоположение каталога Android SDK, который вы недавно загрузили и распаковали.
  3. Нажмите « Next .
  4. Теперь ваша Eclipse IDE настроена на разработку приложений для Android, но вам необходимо добавить в свою среду новейшие инструменты платформы SDK и платформу Android .
  5. Чтобы получить эти пакеты для вашего SDK, продолжайте добавлять платформы и пакеты .

Вы также можете получить обновленную версию плагина ADT, которая добавляет поддержку новейшего NDK и исправляет некоторые ошибки, связанные с собственной отладкой C / C ++ по адресу: https://github.com/khaledev/ADT

В июле 2017 года Eclipse Oxygen отключен, и ADT слабо поддерживается (или не поддерживается). Но по-прежнему часто необходимо, чтобы они работали вместе (причины разные). Вот инструкция по подключению Eclipse Oxygen (последняя на момент написания) с ADT на Ubuntu Linux 16.04 (последняя версия LTS).

  1. Я начал с чистой установки Ubuntu
  2. Установить OpenJDK 8 sudo apt-get install openjdk-8-jdk
  3. Мне нужен OpenJDK 7 для моего проекта (пропустите, если не нужно)

     sudo add-apt-repository ppa:openjdk-r/ppa sudo apt-get update sudo apt-get install openjdk-7-jdk 
  4. Загрузите Eclipse Oxygen (я выбрал пакет Java) и установите.
  5. Запустите Eclipse и закройте экран приветствия, дойдите до места, где есть пустая рабочая область
  6. В своем браузере зайдите в Eclipse Marketplace, где предоставляется ADT. На момент написания он был здесь .
  7. Перетащите кнопку «Установить» с веб-страницы на панель рабочей станции в запущенном Eclipse (размер ваших окон, чтобы вы могли видеть оба). При перетаскивании курсора курсор будет иметь знак плюса. Затем «снимите» / отпустите значок. Установка должна исходить оттуда.
  8. Eclipse попросит перезагрузить, сделайте это.
  9. Android SDK не будет найден, следуйте инструкциям, чтобы получить одну настройку.
  10. Инструменты сборки SDK могут быть устаревшими, вызывая ошибку, но ADT предложит установить последнюю версию, следуя инструкциям.
  11. У меня была ошибка ADB в окне журнала, пока я не закончил настройку SDK и инструмента, а затем перезапустил Eclipse.

Надеюсь это поможет.