Intereting Posts
Перетаскивание + пользовательский чертеж на Android ListView / ExpandableListView setEmptyView () не влияет Построение RatingBar с использованием изображений, загруженных из Интернета. Gradle не работает после обновления до Android-студии 2.3 Canary 3 Наземная ионная 2 геолокация не работает на устройстве Android Объявление Admob не рисуется, но есть ли? (LibGDX Admob 6.4.1) Как получить битмап из Uri? Как остановить прокрутку родительского прокрутки, когда прокрутка прокрутки прокручивается в андроиде? Определить, установлено ли приложение из Play-магазина Arm-linux-androideabi-g ++. Exe: CreateProcess: Нет такой ошибки в файле или каталоге Включить предварительно созданную статическую библиотеку Должен ли внутренний класс DialogFragment статичным или нет? Удалить элемент из пользовательского списка просмотра при нажатии кнопки OnQueryTextChange запускается после возобновления приложения Предотвращение использования RecyclerView для использования событий касания

Как импортировать удаленную библиотеку в Android Studio с помощью gradle?

Я пытаюсь импортировать android-swipelistview ( https://github.com/47deg/android-swipelistview ) в свой модуль Android Studio, используя gradle. Не должно ли это быть возможно с помощью build.gradle config? Кто-нибудь имеет конфигурационный файл (ы), который выполняет эту работу?

Вы можете использовать:

compile 'com.nineoldandroids:library:2.4.0' 

Или если у вас есть библиотека, скопированная в каталог проекта libs, вы можете использовать:

 compile files ('libs/ nineoldandroids-2.4.0.jar') 

Тем не менее, вы можете проверить мой пост при начале работы с swipelistview: http://modewagon.wordpress.com/2013/09/16/getting-started-with-swipelistview/

Я получал ошибку Failed to Resolve в этой библиотеке. Исправление для меня было в файле build.gradle , чтобы изменить это:

 repositories { mavenCentral() } 

к этому:

 repositories { jcenter { url "http://jcenter.bintray.com/" } } 

Если компиляция 'com.nineoldandroids: library: 2.4.0+' не работает,

Попробуйте это -> compile 'com.nineoldandroids: library: 2.4. +'