Intereting Posts
Где должны быть записаны вызовы службы android для GoogleAPIClient при использовании шаблона MVP в android? Как правильно сделать снимок экрана во всем мире? Как изменить цвет текста заголовка и цвет без изменения цвета текста меню переполнения текста в новой панели инструментов? Зачем мне нужно разрешение WRITE_EXTERNAL_STORAGE с getExternalCacheDir () на Android Lollipop? Уведомление об андроиде не вызывает запуск BroadcastReceiver onReceive Android-градир дублирует собственные общие библиотеки Плагин Android Studio и Bitbucket Java.lang.NoSuchFieldError: org.apache.http.message.BasicLineFormatter.INSTANCE Как приложение может включить «Разрешить автоматическое обновление» на Android-рынке Android File Picker Можно ли изменить, где сохраняются виртуальные устройства Android? В чем разница между AppBarLayout и панелью инструментов? Отображать анимированные GIF Как получить доступ к getFilesDir () как переменную среды? UnsatisfiedLinkError в нативном методе

Не удалось получить модель типа «IdeaProject» с использованием установки Gradle

Я загрузил и установил Android Studio со всеми необходимыми зависимостями, такими как JDK 1.7 и Gradle 1.6. Я могу успешно импортировать проекты и модули в Studio, но когда я пытаюсь создать новый проект, я получаю такие ошибки:

Образ

Поскольку это новорожденная среда IDE, я не мог найти много деталей об этом, кроме этого и этого . Любая помощь будет принята с благодарностью.

Solutions Collecting From Web of "Не удалось получить модель типа «IdeaProject» с использованием установки Gradle"

После того, как я потратил много времени на это, я решил:

Используете ли вы «версию Windows» AS?

Выполните следующие действия:

1 - Install the last version of JDK with respective JAVA_HOME variable. 2 - Download and Install Gradle1.6 with respective GRADLE_HOME variable, 

http://www.gradle.org/docs/current/userguide/userguide_single.html#installation .

 2 - Delete these folders: C:\Users\youruser\.AndroidStudioPreview C:\Users\youruser\.android C:\Users\youruser\.gradle 3 - Reopen Android Studio Now probably it will works 

В «Предварительном предварительном просмотре» есть много ошибок ….

В диалоговом окне ошибки упоминается Gradle 1.4

Android Studio требует плагин Gradle 0.4, для которого требуется Gradle 1.6

Я попробовал использовать переменную окружения и местоположение папки, также удостоверился, что у меня была последняя версия Gradle, но это не улучшилось. Затем я запустил Android Studio, используя учетную запись администратора, после чего все ошибки исчезли. Если вы в состоянии, я предлагаю вам сделать то же самое. Это было в окне Windows 7.

Для меня эта проблема вызвана тем, что файл local.properties показывает другой путь к Android SDK. Я занимаюсь разработкой как на Mac OS X, так и на Windows, а в файле свойств отображается мой путь к Mac OS X SDK. Оказывается, этот файл не должен быть проверен в качестве источника. По электронной почте Ой!

Исправление для меня было на странице Известные проблемы здесь: http://tools.android.com/knownissues

Я изменился

 dependencies { classpath 'com.android.tools.build:gradle:0.4' } 

чтобы:

 dependencies { classpath 'com.android.tools.build:gradle:0.5.+' } 

Открытая Android Studio и вуаля!

Лучшее решение, которое я нашел, – проверить пустой проект, а затем импортировать его, а не использовать утилиту «Новый проект».

Я исправил проблему, загрузив новую копию AndroidStudio. Во время одного из обновлений что-то пошло не так, поэтому я удаляю все файлы конфигурации и только что загрузил файл из Интернета, а затем он отлично работал для меня.

(Я нахожусь на Mac)

Я решил это, установив некоторые дополнения из Android SDK, что я не думал, что мне нужно: Google Repository и сервисы Google Play. Помимо репозитория поддержки Android.

При ручном управлении градиентом вы получаете более значимые сообщения об ошибках.

Если вы все еще получаете эту ошибку при создании нового проекта, попробуйте открыть проект (после ошибки) и удалить из своего файла build.gradle в своем модуле следующее.

 dependencies { compile 'com.android.support:support-v4:13.0.+' }