Обновлено до 2.3, теперь сборки муравьев не включают баны в моем каталоге libs

Я делал все свои сборки, используя ant в командной строке (Ubuntu 10.04). Я загрузил 2.3 SDK и изменил необходимый путь (платформенные инструменты). Теперь мои сборки не содержат баночки в моем каталоге libs. Любые мысли о том, что мне нужно изменить?

Система сборки Ant теперь требует Ant 1.8+. К сожалению, она «работает» (сломанная) с 1.7, потому что мы полагаемся на новое поведение в 1.8, а не на новую задачу или атрибут, который сломал бы 1.7

Я не знаком с ant builde для android, так как я зашифровал usig (почему бы не ou? Он автоматически генерирует build.xml). В любом случае, вы говорите, что инструменты платформы вы имеете в виду $ ANDROID_HOME / platform / android-9? Вы уверены, что это необходимо для муравья? Я знаю, что сам файл сборки ant довольно пуст, и большая часть работы выполняется в их java-файлах .sh, поэтому вам нужно сообщить, что им не хватает, холодно, что вы обнаружили ошибку в своем новом SDK?

У меня есть другие более серьезные проблемы с SDK2.3 (AVD's bust). Я установил Ant builds OK, чтобы работать с версией 2.2 и хотел посмотреть, будет ли работать Ant-сборка. Мой пользовательский build.xml перегрузил совсем немного материала в ant_rules_r3.xml, но все еще использовал его. Я заметил, что теперь это было удалено и заменено на main_rules.xml, что немного отличается. 'Project.libraries' заменяет 'android.libraries' для чего-то. Вероятно, стоит посмотреть на различия, если ваш build.xml был основан на ant_rules_3.

Я не буду смотреть на него сам, пока не будет исправлена ​​моя главная проблема.