Ошибка: Джек должен поддерживать java 8 языковые функции

Когда я попытался обновить свой проект андроида, чтобы использовать Java 8 после получения android studio 2.1 и Android SD SDK, добавив

compileOptions { sourceCompatibility JavaVersion.VERSION_1_8 targetCompatibility JavaVersion.VERSION_1_8 } 

У меня была эта ошибка

Ошибка: Джек должен поддерживать java 8 языковые функции. Либо включите Джек, либо удалите исходную совместимость JavaVersion.VERSION_1_8.

Что мне делать?

    Ошибка: Джек должен поддерживать java 8 языковые функции. Либо включите Джек, либо удалите исходную совместимость JavaVersion.VERSION_1_8.

    Ошибка говорит, что вам нужно включить Jack .

    Чтобы включить поддержку Java 8 в вашем проекте Android, вам необходимо настроить файл build.gradle таким образом

     android { ... compileSdkVersion 23 buildToolsVersion "24rc2" defaultConfig { ... jackOptions { enabled true } } compileOptions { sourceCompatibility JavaVersion.VERSION_1_8 targetCompatibility JavaVersion.VERSION_1_8 } }