Intereting Posts
Значение для 'keystore' недопустимо. Он должен решить один путь React Native – packager висит на преобразовании (100% 393/394) в демонстрационном приложении (Android) Ресурс существует с другим случаем Сериализовать параметр запроса в дооснащении Обновление запущенного приложения на Android Как закрепить заголовок на панели инструментов внутри CollapsingToolbarLayout Проверка наличия столбца в базе данных приложений на Android Android. При переключении между двумя действиями вызывающий порядок методов жизненного цикла Activity Платформа Android Transition и данные из сети Пользовательские вкладки в android Что делать, если я хочу опубликовать обновление с более высоким значением minSDK, чем тот, который представлен на рынке? Как добавить значок перетаскивания с навигационным ящиком Ошибка камеры «Не удается подключиться к камере» или на некоторых телефонах появляется ошибка «Камера используется другим приложением», Список разрешений Android для обычных разрешений и опасных разрешений в API 23? ListView с Custom ArrayAdapter не обновляется

Ошибка при добавлении зависимостей в Android Studio

Когда я хочу добавить новую библиотеку в файл build.gradle, она генерирует ошибку. Это мой файл build.gradle:

// Top-level build file where you can add configuration options common to all sub-projects/modules. buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:1.0.0' compile 'com.mcxiaoke.volley:library:1.0.+' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { jcenter() } } 

И это ошибка

C: \ Users \ Fakher \ Documents \ Play_Store_WS \ VolleyJson \ build.gradle Ошибка: ошибка: строка (10) Метод Gradle DSL не найден: 'compile ()' Возможные причины:

  • В проекте «VolleyJson» может использоваться версия Gradle, которая не содержит метода. Настройки горловины
  • В файле сборки может отсутствовать плагин Gradle. Применить плагин Gradle
  • Это не работает, потому что вы помещаете зависимость в неподходящее место, в этом build.gradle нет плагинов для обработки вашей зависимости, вы должны добавить свою зависимость в build.gradle, находящуюся внутри вашего модуля приложения.

    Лучше объяснил:

    В вашем проекте есть папка, называемая приложением , то есть ваш модуль приложения, внутри которой должен быть build.gradle, в этом build.gradle должно быть что-то вроде этого:

      apply plugin: 'com.android.application' android { compileSdkVersion 21 buildToolsVersion "21.1.2" defaultConfig { // bla bla bla } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) //put your dependencies here } 

    Надеюсь, я смогу помочь тебе …

    Вам нужно использовать build.gradle вашего модуля вместо вашего проекта.

    Посмотри на это:

     // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files 

    Идите в build.gradle в свой модуль «App», а затем разместите:

     compile 'com.mcxiaoke.volley:library:1.0.+' 

    Вы должны добавить свои зависимости в buil.gradle под приложением / не в build.gradle под своим проектом