Зависимость игнорируется из-за конфликта Android-студия

Я пытаюсь добавить следующую зависимость, но она игнорируется. Я не могу понять, как его решить, пожалуйста, помогите мне. Спасибо.

зависимость

compile 'com.google.apis:google-api-services-drive:v2-rev170-1.20.0' 

Уход за игнорирование зависимости
Предупреждение. Зависимость org.apache.httpcomponents: httpclient: 4.0.1 игнорируется для отладки, поскольку это может противоречить внутренней версии, предоставляемой Android. В случае возникновения проблемы переупаковывайте его с помощью jarjar для изменения пакетов классов. Предупреждение. Зависимость org.apache.httpcomponents: httpclient: 4.0.1 игнорируется для выпуска, так как может противоречить внутренней версии, предоставляемой Android. В случае возникновения проблемы переупаковать его с помощью jarjar, чтобы изменить пакеты классов

Вы можете исключить зависимости в файле build.gradle вашего модуля.

 compile('com.google.apis:google-api-services-drive:v2-rev170-1.20.0') { exclude module: 'httpclient' //by artifact name exclude group: 'org.apache.httpcomponents' //by group exclude group: 'org.apache.httpcomponents', module: 'httpclient' //by both name and group } 

Исключить модуль httpclient из всех конфигураций. Добавьте этот код в файл build.gradle:

 configurations { compile.exclude group: "org.apache.httpcomponents", module: "httpclient" } 

Используйте следующий код, чтобы исключить конфликтующие модули из библиотеки API Google.

  compile 'com.google.apis:google-api-services-drive:v2-rev170-1.20.0' { exclude module: 'httpcore' exclude module: 'httpclient' }